I hit a snag/Any Chicago x0x'ers?
Moderators: Altitude, adafruit_support_bill, adafruit, phono, mome rath

Re: I hit a snag/Any Chicago x0x'ers?

by synth505 on Tue Aug 28, 2012 9:48 pm

Ok..so I got the headphone amp/mixer and the I/O board done. Taking a break to eat for the first time today before I start on the sequencer..haha
Attachments
DSCN1514.JPG
DSCN1514.JPG (323.49 KiB) Viewed 1325 times
DSCN1512.JPG
DSCN1512.JPG (255.35 KiB) Viewed 1325 times
synth505
 
Posts: 19
Joined: Fri Jul 06, 2012 2:45 pm

Re: I hit a snag/Any Chicago x0x'ers?

by synth505 on Wed Aug 29, 2012 1:37 am

Another update..I have completed about half the sequencer. Going to take a break for the night. All I have left are the tact switches, the LEDs, and the jumpers. I'm thinking i'll probably have it finished tomorrow. Then comes the moment of truth..
Attachments
DSCN1516.JPG
DSCN1516.JPG (410.59 KiB) Viewed 1323 times
DSCN1515.JPG
DSCN1515.JPG (375.73 KiB) Viewed 1323 times
synth505
 
Posts: 19
Joined: Fri Jul 06, 2012 2:45 pm

Re: I hit a snag/Any Chicago x0x'ers?

by MMM on Wed Aug 29, 2012 10:02 am

Looking good.

The whole digital side is actually pretty straightforward (in my opinion).
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: I hit a snag/Any Chicago x0x'ers?

by synth505 on Wed Aug 29, 2012 10:27 pm

Alright, so i've completed it and it works!

I was kind of freaked out at first because I started it up on random mode and it was going so fast that I thought I screwed something up, but I just had to turn the tempo way down.

Anyways..I am having an issue with the front plate, it seems like it is not sitting properly. I have included a picture. You can see how the keys go lower and lower as you get to the right, where the slide key is basically flush/just under the front plate. For some reason I wasn't able to get the screw to turn in the lower right one and stay there. Is this because the LEDs are not straight? It seems like the whole thing should ride a bit higher. How can I fix this?

BTW..will post some audio clips tomorrow when I go to the studio so I can use some nice pre's! =)
Attachments
DSCN1522.JPG
DSCN1522.JPG (289.17 KiB) Viewed 1305 times
synth505
 
Posts: 19
Joined: Fri Jul 06, 2012 2:45 pm

Re: I hit a snag/Any Chicago x0x'ers?

by MMM on Thu Aug 30, 2012 2:34 am

synth505 wrote:Anyways..I am having an issue with the front plate, it seems like it is not sitting properly. I have included a picture. You can see how the keys go lower and lower as you get to the right, where the slide key is basically flush/just under the front plate. For some reason I wasn't able to get the screw to turn in the lower right one and stay there. Is this because the LEDs are not straight? It seems like the whole thing should ride a bit higher. How can I fix this?


I guess you're having the standoffs attached to the PCB? Are they the same size? I believe some kits *may* contain differently sized standoffs for the corners and the remaining three holes; other kist may compensate with additional washers. Does the front panel/enclosure touch all the standoffs (at least those in the corners)? If not, which component is in the way?
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: I hit a snag/Any Chicago x0x'ers?

by synth505 on Thu Aug 30, 2012 3:25 am

MMM wrote:I guess you're having the standoffs attached to the PCB? Are they the same size? I believe some kits *may* contain differently sized standoffs for the corners and the remaining three holes; other kist may compensate with additional washers. Does the front panel/enclosure touch all the standoffs (at least those in the corners)? If not, which component is in the way?


In my kit the 4 corner ones had slightly shorter standoffs, like a mm or two. I ended up taking the case apart so that I could properly tune the synth since I didn't while putting it together. I ended up fixing it by pushing a little harder, there were a few LEDs that were being a hassle, so I moved them slightly. All of the LEDs aren't perfectly in the slots, but they are visible. Putting those LED's and getting them in straight is sure a job!

Anyways, I was able to get that last screw in which pulled those other buttons up, the slide button is no longer getting stuck under the faceplate when I use it.

I am looking forward to posting some audio clips tomorrow!
synth505
 
Posts: 19
Joined: Fri Jul 06, 2012 2:45 pm

Re: I hit a snag/Any Chicago x0x'ers?

by synth505 on Sat Sep 01, 2012 3:17 am

So i've posted a picture and audio clip in the pinned thread, but I had a question about operation. I was under the impression that you could change from pattern edit mode to pattern play mode without the sequencer stopping (OS Sokkos 1.9.1). Whenever I have a sequence running that I edited and then change to pattern play mode the box stops. Is this proper behavior for this version of the OS?
synth505
 
Posts: 19
Joined: Fri Jul 06, 2012 2:45 pm

Re: I hit a snag/Any Chicago x0x'ers?

by antto on Sat Sep 01, 2012 12:38 pm

are you sure it's sokkos on the chip?
if you're not - just flash it yourself
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1355
Joined: Thu Apr 15, 2010 2:21 pm
Location: 127.0.0.1

Re: I hit a snag/Any Chicago x0x'ers?

by synth505 on Sat Sep 01, 2012 5:34 pm

antto wrote:are you sure it's sokkos on the chip?
if you're not - just flash it yourself


It seems to be as it has the loop, swing, and half tempo functions.
synth505
 
Posts: 19
Joined: Fri Jul 06, 2012 2:45 pm

Re: I hit a snag/Any Chicago x0x'ers?

by antto on Sun Sep 02, 2012 3:18 am

i just tested
if i run it from PATTERN PLAY mode and then switch to EDIT mode - it doesn't stop
if i run it from PATTERN EDIT mode and then switch to PLAY mode - it stops (stops when it hits MIDISYNC)

however, if you originally ran it from PLAY mode - you can go back and forward between PLAY and EDIT without stoping
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1355
Joined: Thu Apr 15, 2010 2:21 pm
Location: 127.0.0.1