Re: New Experimental OS for x0xb0x adds DIN Swing

by machine.cuisine on Tue May 15, 2012 6:08 pm

Dear Omsk (and Sokk, since it's based off of Sokk 2.0) - I'm very excited to try this out! I'm waiting on a new SMS x0xb0x from across the sea and the first thing I'm gonna do is load up this here 0.94 OS.

I just wanted to say that between Sokk's 2.0 version with triplets and transposition and now your cool dinsync upgrades - I was finally convinced to get a x0xb0x! I can't wait. Thanks for your hard work - and thanks to Sokk of course!!!

The only other feature I would like to see is 32nd notes! Maybe I can take a peep at this sequencer code soon enough.
machine.cuisine
 
Posts: 9
Joined: Tue May 15, 2012 5:59 pm

Re: New Experimental OS for x0xb0x adds DIN Swing

by pangrus on Thu May 17, 2012 5:29 am

Hi everybody,
Testing 0.94 beta.
When slaved to midi (PATT MIDI SYNC mode) everyhing works now, default mode (USER A) is good for my Electribe Er1. In USER B the Xox is ahead the midi master (weird but true).
Swing works but I can feel only three swing settings, and I have to press the PREV or NEXT button twice to pass from one to the other. Am I wrong?
When Xox is master (PATTERN SYNC OUT), at high swing level, my 303 goes out of sync.

Hope this may help,
Cheers.
User avatar
pangrus
 
Posts: 42
Joined: Fri Feb 25, 2011 9:20 am

Re: New Experimental OS for x0xb0x adds DIN Swing

by machine.cuisine on Fri May 25, 2012 3:36 pm

ok, I finally got my x0xb0x from Andy Pledger (awesome) and I've uploaded this 0.94 firmware (was using sokk 1.9 for the last couple days - haven't tried 2.0 yet).

anyways, "Triplet Mode" doesn't work correctly. I have a tr-606 slaved via dinsync to the x0xb0x. No good. x0xb0x moves a lot faster than the 606. the "fast" 606 triplet mode doesn't help at all either.

I need to upload sokk 2.0 and see if triplet mode works correctly with that, but I can say for sure that it doesn't work with omsk 0.94.
machine.cuisine
 
Posts: 9
Joined: Tue May 15, 2012 5:59 pm

Re: New Experimental OS for x0xb0x adds DIN Swing

by am4d on Mon Jun 11, 2012 7:10 am

So i flashed my xox for the first time recently and tested SokkOS 2.0 and Omskos 0.94 beta. Triplets definitely aren't working correctly in either. As machine.cuisine pointed out, the xox runs faster than a 606 set to the same time sig, also triplets seem to work when the xox is slaved to the 606 clock, so it seems the xox is sending a messed up Din Sync clock in triplet mode.
Swing on Din Sync works pretty good, i can get 4 levels of swing and the 5th gets all messed up, even at slow speeds.

And i really wanted to try the "stop and start Din Sync" but i don't have a MIDI clock source right now so I'm running of the xox internal clock, switching to MIDI Sync while running and pressing run just stops everything. I was hoping for a way to do this when the xox isn't slaved to MIDI? Ill have a MIDI clock soon anyway but im assuming this is why its not working?

The firmware is really coming along though, can't wait for a v1.0
I was also thinking it would be really nice to be able to swing just Din, or just xox, or both. Does anyone else think that would be handy?
am4d
 
Posts: 21
Joined: Tue Dec 27, 2011 4:17 pm

Re: New Experimental OS for x0xb0x adds DIN Swing

by am4d on Fri Jul 06, 2012 3:47 am

Cant figure out how to edit my post :S

I figured out triplets do kind of work. When slaving something like a 606 you need the 606 to be set to the regular 4/4 timing but with the pattern shortened, then they step in time together. But the timing makes the 606 sound really jerky, whereas the other way around, a xox slaved to a 606, its a lot more stable and sounds a lot better.
am4d
 
Posts: 21
Joined: Tue Dec 27, 2011 4:17 pm

Re: New Experimental OS for x0xb0x adds DIN Swing

by elektrovolt on Sun Jul 22, 2012 7:39 am

did a re-flash with the latest version, slaved to midi clock the sequencer runs like banned. extreme jitter. the 808 slaved to the sync out does something identical.
re-flashed a few times but still no success. anyone else has this problem?
NI !!!
elektrovolt
 
Posts: 20
Joined: Sun Oct 23, 2005 2:24 pm
Location: NL

Re: New Experimental OS for x0xb0x adds DIN Swing

by jmejia on Mon Feb 04, 2013 10:50 pm

I've been frustrated with this x0x clock being behind for awhile - thought maybe mine was the only one!! I get a one tick behind problem slaving my x0x to my octatrack, and then slaving my 808 via dinsync to the x0x.

Unfortunately your new firmware didn't work for me at all. I get HUGE timing drifts on the dinsync output. Anyone else experiencing this?
jmejia
 
Posts: 11
Joined: Mon Aug 25, 2008 3:15 pm