using iphone to debug VCO's!
Moderators: adafruit_support_bill, adafruit

using iphone to debug VCO's!

by powerpants on Tue Apr 08, 2008 9:24 pm

Just thought I'd share a cool trick I've figured over the course of my build. I've just put in the VCO's and PLL (about to start on the amp section) and I wanted to make sure that they were both functioning correctly.

So, I used the field test mode on my iphone.

If you dial *3001#12345#* on the iphone and press "call," it will bring up the field test mode. If you click on "cell information," it will show data about all the nearby towers that the phone can see. The "fq" value next to each one indicates what band it is operating on - if it's between 128 and 251, that tower is operating on the 850MHz band. If the number's between 512 and 810, then the tower is on the 1900MHz band.

I turned on my WB (with primitive antennas) and after a couple of seconds, all the towers disappeared, and were replaced with one having a fq of of 0 - I guess that the phone is seeing the WB as a really messed up tower or something.

This result means that both VCO's are working - if only one or the other was working, then the towers broadcasting on the frequency corresponding to the malfunctioning VCO would not disappear.
powerpants
 
Posts: 42
Joined: Tue Feb 26, 2008 7:55 pm

by WBVenom on Fri Apr 11, 2008 9:48 pm

Nice! Thanks for the awesome info. I'll certainly be employing a few friends' iPhones soon.
WBVenom
 
Posts: 17
Joined: Fri Apr 11, 2008 2:33 am

Re: using iphone to debug VCO's!

by losthorizonmba on Tue Jun 12, 2012 4:53 am

Is this possible only in unlocked/hijacked phones
User avatar
losthorizonmba
 
Posts: 31
Joined: Wed Sep 15, 2010 10:41 pm