usbtiny not working at all
Moderators: adafruit_support_bill, adafruit

usbtiny not working at all

by WeldaSB on Mon Feb 18, 2013 4:09 pm

1) kit from adafruit
2) custom-built desktop running linux mint
also tested on winxp laptop
3)AVRdude with uno-328 and an unprogrammed 328
4)nope, not once
5)
Image
Image
(the stuff on the back is just flux)

The only output I can get is
Code: Select all | TOGGLE FULL SIZE
# avrdude -c usbtiny -p ATmega328P -B8

avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

and
Code: Select all | TOGGLE FULL SIZE
# avrdude -c usbtiny -p ATmega328P -B8 -F

avrdude: initialization failed, rc=-1
avrdude: AVR device initialized and ready to accept instructions
avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.                                                                                                                                         
avrdude: Expected signature for ATMEGA328P is 1E 95 0F                                                                                                                             
                                                                                                                                                                                   
avrdude done.  Thank you.                                                                                                                                                           


I asked on avrfreaks on this, but I also wanted the manufacturer's input:
http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&p=1038873#1038873
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by adafruit_support_rick on Mon Feb 18, 2013 10:02 pm

Actually, that output means that the USBtiny is working, but it's not able to communicate with the target chip.
See here: http://www.ladyada.net/make/usbtinyisp/help.html
User avatar
adafruit_support_rick
 
Posts: 11586
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: usbtiny not working at all

by WeldaSB on Sat Feb 23, 2013 2:51 am

I have confirmed everything on that list, and I get the same output. I have tried it with an uno, and a breadboard atmega, but I get the same output
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by adafruit_support_rick on Sat Feb 23, 2013 9:24 am

I don't know. Your build looks OK in the pictures.
On the Uno, are you sure you had the 6-pin cable oriented the right way? Did you try it both ways?
Did you try removing the power jumper on the USBtiny and powering the Uno through the barrel jack instead?
User avatar
adafruit_support_rick
 
Posts: 11586
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: usbtiny not working at all

by WeldaSB on Sun Feb 24, 2013 7:54 pm

I tried both ways on the uno, and broken out connected to the correct uno pins, and on a breadboard with another atmega328 that had no bootloader, but I always got the same message. Could the buffer chip be broken or something? I am learning c and need something to program with.
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by WeldaSB on Sun Feb 24, 2013 7:56 pm

Couldn't find the edit button
Yes, I have tried it separately powered.
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by adafruit_support_rick on Mon Feb 25, 2013 8:48 am

Let's try something different. There is another ICSP 6-pin header next to the USB jack on your Uno. Attach the programming cable there, as in this picture.
uno.JPG
uno.JPG (167.67 KiB) Viewed 2042 times

Don't attach any power or usb cables to the uno. Make sure the ON LED is illuminated. Then, issue the following command to avrdude:

avrdude -c usbtiny -p m16u2

Post the response here.
User avatar
adafruit_support_rick
 
Posts: 11586
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: usbtiny not working at all

by WeldaSB on Sat Mar 02, 2013 4:12 pm

Code: Select all | TOGGLE FULL SIZE
avrdude -c usbtiny -p m16u2

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x1e9489

avrdude: safemode: Fuses OK

avrdude done.  Thank you.


But I still get the old output with a breadboard 328 or the uno 328
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by adafruit_support_rick on Sun Mar 03, 2013 1:44 pm

Well, that's pretty definitive. The USBTiny is working. Your problem is going to be with the 328.

I had a look at the AVRFreaks topic you linked to. As I understand it, you broke a pin and installed a ZIF socket? The pin you broke isn't related to ICSP, so I have to conclude that there's a problem with your ZIF socket - either the socket itself has a problem, or its connection to the UNO is not secure.

Did you solder the ZIF socket in place of the DIP socket? Check your solders. If you'd like, feel free to post some pictures of your UNO, and we'll see if we can spot any problems.
User avatar
adafruit_support_rick
 
Posts: 11586
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: usbtiny not working at all

by WeldaSB on Sun Mar 03, 2013 2:29 pm

i have 2 atmega328p. one is just plain with no bootloader, the other has arduino bootloader and a broken pin. i got the plain one to work:Image

the bootloader programmed one will not work:
Image

I had the zif socket pushed into the dip slot, but removed it for these tests.
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by WeldaSB on Sun Mar 03, 2013 2:30 pm

i had the zif socket out because the isp header won't go on when it is in.
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by adafruit_support_rick on Sun Mar 03, 2013 3:25 pm

Sounds like you must have damaged more than just pin 15 on that 328. If there's nothing else obvious, the chip is probably toasted.
User avatar
adafruit_support_rick
 
Posts: 11586
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: usbtiny not working at all

by WeldaSB on Sun Mar 03, 2013 3:48 pm

Well thanks so much for helping me. the bbroken chip still seems to work with the arduino ide, so i guess i can still use it. thank yoiu for this product and not having to pay $40.
WeldaSB
 
Posts: 8
Joined: Tue Jan 01, 2013 11:15 pm

Re: usbtiny not working at all

by adafruit_support_rick on Sun Mar 03, 2013 10:54 pm

No problem :D
Good luck!
User avatar
adafruit_support_rick
 
Posts: 11586
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY