programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by rguindon on Fri Apr 01, 2011 4:59 pm

I just bought the starter kit. I am a software engineer and I did mentor programming for FIRST robotics when they used MPLAB.

I have not been able to get the BLINK program to load properly. avrdude: stk500_getsync(): not in sync: resp=0x00

I am confident that I have properly installed the driver-- c:\arduino-0022\drivers\arduino uno.inf --
see the Windows/inf/setupapi.dev below inf: Opened INF: 'c:\arduino-0022\drivers\arduino uno.inf' ([strings]) <<< Section end 2011/03/31 17:56:43.247
<<< [Exit status: SUCCESS]

Windows 7 professional 64-bit
Arduino 0022
Tools->board-> Arduino UNO
Tools->Serial Port->COM9
(device manager shows port arduino Uno (COM9)

I have set in AppData/Roaming/Arduino/preferences.txt (when Arduino was not running)
I run upload.verbose=true (shift upload)

The power LED (green) is on the UNO.
The little yellow LED normally flashes about once every 1.5 second
TX and RX blink when I try an upload.

I get
Using Port : COM9
Using Programmer : stk500v1
Overriding Baud Rate : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

Windows/inf/setupapi.dev log file
Code: Select all
>>>  [Device Install (DiShowUpdateDevice) - USB\VID_2341&PID_0001\64932343738351706180]
>>>  Section start 2011/03/31 17:55:53.900
      cmd: "C:\Windows\system32\mmc.exe" C:\Windows\system32\devmgmt.msc
     dvi: {DIF_UPDATEDRIVER_UI} 17:55:53.901
     dvi:      No class installer for 'Arduino Uno'
     dvi:      No CoInstallers found
     dvi:      Default installer: Enter 17:55:53.905
     dvi:      Default installer: Exit
     dvi: {DIF_UPDATEDRIVER_UI - exit(0xe000020e)} 17:55:53.908
     ndv: {Update Driver Software Wizard for USB\VID_2341&PID_0001\64932343738351706180}
     inf:      Opened INF: 'c:\arduino-0022\drivers\arduino uno.inf' ([strings])
     inf:      {SetupCopyOEMInf: c:\arduino-0022\drivers\arduino uno.inf} 17:55:58.381
     sto:           {Import Driver Package: c:\arduino-0022\drivers\arduino uno.inf} 17:55:58.389
     sto:                Importing driver package into Driver Store:
     sto:                     Driver Store   = C:\Windows\System32\DriverStore (Online | 6.1.7600)
     sto:                     Driver Package = c:\arduino-0022\drivers\arduino uno.inf
     sto:                     Architecture   = amd64
     sto:                     Locale Name    = neutral
     sto:                     Flags          = 0x00000000
     sto:                Copying driver package files to 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}'.
     inf:                Opened INF: 'c:\arduino-0022\drivers\arduino uno.inf' ([strings])
!    inf:                Could not find include INF file "layout.inf". Error = 0x00000002
     inf:                Opened INF: 'C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_774523d133de6343\mdmcpq.inf' ([strings])
     inf:                Opened INF: 'c:\arduino-0022\drivers\arduino uno.inf' ([strings])
     flq:                {FILE_QUEUE_COPY}
     flq:                     CopyStyle      - 0x00000000
     flq:                     SourceRootPath - 'c:\arduino-0022\drivers'
     flq:                     SourceFilename - 'arduino uno.inf'
     flq:                     TargetDirectory- 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}'
     flq:                {FILE_QUEUE_COPY exit(0x00000000)}
     flq:                {_commit_file_queue}
     flq:                     CommitQ DelNodes=0 RenNodes=0 CopyNodes=1
     flq:                     {_commit_copy_subqueue}
     flq:                          subqueue count=1
     flq:                          source media:
     flq:                               SourcePath   - [c:\arduino-0022\drivers]
     flq:                               SourceFile   - [arduino uno.inf]
     flq:                               Flags        - 0x00000000
     flq:                          {_commit_copyfile}
     flq:                               CopyFile: 'c:\arduino-0022\drivers\arduino uno.inf'
     flq:                                     to: 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\SET5882.tmp'
     flq:                               MoveFile: 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\SET5882.tmp'
     flq:                                     to: 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\arduino uno.inf'
     flq:                          {_commit_copyfile exit OK}
     flq:                     {_commit_copy_subqueue exit OK}
     flq:                {_commit_file_queue exit OK}
     pol:                {Driver package policy check} 17:55:59.386
     pol:                {Driver package policy check - exit(0x00000000)} 17:55:59.387
     sto:                {Stage Driver Package: C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\arduino uno.inf} 17:55:59.388
     inf:                     Opened INF: 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\arduino uno.inf' ([strings])
!    inf:                     Could not find include INF file "layout.inf". Error = 0x00000002
     inf:                     Opened INF: 'C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_774523d133de6343\mdmcpq.inf' ([strings])
     inf:                     Opened INF: 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\arduino uno.inf' ([strings])
     sto:                     Copying driver package files:
     sto:                          Source Path      = C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}
     sto:                          Destination Path = C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}
     flq:                     {FILE_QUEUE_COPY}
     flq:                          CopyStyle      - 0x00000010
     flq:                          SourceRootPath - 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}'
     flq:                          SourceFilename - 'arduino uno.inf'
     flq:                          TargetDirectory- 'C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}'
     flq:                     {FILE_QUEUE_COPY exit(0x00000000)}
     flq:                     {_commit_file_queue}
     flq:                          CommitQ DelNodes=0 RenNodes=0 CopyNodes=1
     flq:                          {_commit_copy_subqueue}
     flq:                               subqueue count=1
     flq:                               source media:
     flq:                                    SourcePath   - [C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}]
     flq:                                    SourceFile   - [arduino uno.inf]
     flq:                                    Flags        - 0x00000000
     flq:                               {_commit_copyfile}
     flq:                                    CopyFile: 'C:\Users\rguindon\AppData\Local\Temp\{28d43398-f0ac-68e5-383b-ea67d5e18935}\arduino uno.inf'
     flq:                                          to: 'C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}\SET5C69.tmp'
     flq:                                    MoveFile: 'C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}\SET5C69.tmp'
     flq:                                          to: 'C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}\arduino uno.inf'
     flq:                               {_commit_copyfile exit OK}
     flq:                          {_commit_copy_subqueue exit OK}
     flq:                     {_commit_file_queue exit OK}
     sto:                     {DRIVERSTORE_IMPORT_NOTIFY_VALIDATE} 17:55:59.462
!    sto:                          Driver package does not contain a catalog file, but user wants to install anyway.
     sto:                     {DRIVERSTORE_IMPORT_NOTIFY_VALIDATE exit(0x00000000)} 17:56:02.401
     sto:                     Verified driver package signature:
     sto:                          Digital Signer Score = 0xFF000000
     sto:                          Digital Signer Name  = <unknown>
     sto:                     {DRIVERSTORE_IMPORT_NOTIFY_BEGIN} 17:56:02.404
     inf:                          Opened INF: 'C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}\arduino uno.inf' ([strings])
     sto:                          Create system restore point:
     sto:                               Description = Device Driver Package Install: Arduino LLC (http://www.arduino.cc) Ports (COM & LPT)
     sto:                               Time        = 15132ms
     sto:                               Status      = 0x00000000 (SUCCESS)
     sto:                     {DRIVERSTORE_IMPORT_NOTIFY_BEGIN: exit(0x00000000)} 17:56:17.538
     sto:                     Importing driver package files:
     sto:                          Source Path      = C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}
     sto:                          Destination Path = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571
     sto:                     {Copy Directory: C:\Windows\System32\DriverStore\Temp\{44777266-349c-717c-c1cd-2c27a5ec5e2c}} 17:56:17.543
     sto:                          Target Path = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571
     sto:                     {Copy Directory: exit(0x00000000)} 17:56:17.547
     sto:                     {Index Driver Package: C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf} 17:56:17.548
     idb:                          Registered driver store entry 'arduino uno.inf_amd64_neutral_21f372cd0616c571'.
     idb:                          Published 'arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' to 'C:\Windows\INF\oem49.inf'
     idb:                          Published driver store entry 'arduino uno.inf_amd64_neutral_21f372cd0616c571'.
     sto:                          Published driver package INF 'oem49.inf' was changed.
     sto:                          Active published driver package is 'arduino uno.inf_amd64_neutral_21f372cd0616c571'.
     sto:                     {Index Driver Package: exit(0x00000000)} 17:56:18.076
     sto:                     {DRIVERSTORE_IMPORT_NOTIFY_END} 17:56:18.078
     sto:                          Commit system restore point:
     sto:                               Description = Device Driver Package Install: Arduino LLC (http://www.arduino.cc) Ports (COM & LPT)
     sto:                               Time        = 0ms
     sto:                               Status      = 0x00000000 (SUCCESS)
     sto:                     {DRIVERSTORE_IMPORT_NOTIFY_END: exit(0x00000000)} 17:56:18.135
     sto:                {Stage Driver Package: exit(0x00000000)} 17:56:18.138
     ndv:                Doing device matching lookup!
     inf:                Opened INF: 'C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     inf:                Saved PNF: 'C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.PNF' (Language = 0409)
     ndv:                Found device that matches new INF!
     sto:                Driver package was staged to Driver Store. Time = 23244 ms
     sto:                Imported driver package into Driver Store:
     sto:                     Filename = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf
     sto:                     Time     = 23290 ms
     sto:           {Import Driver Package: exit(0x00000000)} 17:56:21.696
     inf:           Opened INF: 'c:\arduino-0022\drivers\arduino uno.inf' ([strings])
     inf:           Opened INF: 'c:\arduino-0022\drivers\arduino uno.inf' ([strings])
     inf:           Installing catalog CDC_vista.cat as: oem49.CAT
!    inf:           Failed to install catalog - error ignored
!    inf:           Error 2: The system cannot find the file specified.
     inf:      {SetupCopyOEMInf exit (0x00000000)} 17:56:22.381
     inf:      Opened PNF: 'C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     sig:      {_VERIFY_FILE_SIGNATURE} 17:56:22.391
     sig:           Key      = arduino uno.inf
     sig:           FilePath = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf
     sig:           Catalog  = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\CDC_vista.cat
!    sig:           Verifying file against specific (valid) catalog failed! (0x00000057)
!    sig:           Error 87: The parameter is incorrect.
     sig:      {_VERIFY_FILE_SIGNATURE exit(0x00000057)} 17:56:22.401
     sig:      {_VERIFY_FILE_SIGNATURE} 17:56:22.402
     sig:           Key      = arduino uno.inf
     sig:           FilePath = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf
     sig:           Catalog  = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\CDC_vista.cat
!    sig:           Verifying file against specific Authenticode(tm) catalog failed! (0x80092003)
!    sig:           Error 0x80092003: An error occurred while reading or writing to a file.
     sig:      {_VERIFY_FILE_SIGNATURE exit(0x80092003)} 17:56:22.411
     dvi:      Selected driver installs from section [DriverInstall] in 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf'.
     dvi:      Set selected driver complete.
     dvi:      {Plug and Play Service: Device Install for USB\VID_2341&PID_0001\64932343738351706180}
     ump:           Creating Install Process: DrvInst.exe 17:56:22.428
     ndv:           Infpath=C:\Windows\INF\oem49.inf
     ndv:           DriverNodeName=arduino uno.inf:DeviceList.NTamd64:DriverInstall:5.1.2600.0:usb\vid_2341&pid_0001
     ndv:           DriverStorepath=C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf
     ndv:           Building driver list from driver node strong name...
     inf:           Opened PNF: 'C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     sig:           {_VERIFY_FILE_SIGNATURE} 17:56:22.672
     sig:                Key      = arduino uno.inf
     sig:                FilePath = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf
     sig:                Catalog  = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\CDC_vista.cat
!    sig:                Verifying file against specific (valid) catalog failed! (0x00000057)
!    sig:                Error 87: The parameter is incorrect.
     sig:           {_VERIFY_FILE_SIGNATURE exit(0x00000057)} 17:56:22.690
     sig:           {_VERIFY_FILE_SIGNATURE} 17:56:22.691
     sig:                Key      = arduino uno.inf
     sig:                FilePath = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf
     sig:                Catalog  = C:\Windows\System32\DriverStore\FileRepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\CDC_vista.cat
!    sig:                Verifying file against specific Authenticode(tm) catalog failed! (0x80092003)
!    sig:                Error 0x80092003: An error occurred while reading or writing to a file.
     sig:           {_VERIFY_FILE_SIGNATURE exit(0x80092003)} 17:56:22.696
     dvi:           Selected driver installs from section [DriverInstall] in 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf'.
     dvi:           Set selected driver complete.
     ndv:           {Core Device Install} 17:56:22.701
     inf:                Opened INF: 'C:\Windows\INF\oem49.inf' ([strings])
     inf:                Saved PNF: 'C:\Windows\INF\oem49.PNF' (Language = 0409)
     dvi:                {DIF_ALLOW_INSTALL} 17:56:22.715
     dvi:                     Using exported function 'PortsClassInstaller' in module 'C:\Windows\system32\MsPorts.Dll'.
     dvi:                     Class installer == MsPorts.Dll,PortsClassInstaller
     dvi:                     No CoInstallers found
     dvi:                     Class installer: Enter 17:56:22.724
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:56:22.725
     dvi:                     Default installer: Exit
     dvi:                {DIF_ALLOW_INSTALL - exit(0xe000020e)} 17:56:22.726
     ndv:                Installing files...
     dvi:                {DIF_INSTALLDEVICEFILES} 17:56:22.729
     dvi:                     Class installer: Enter 17:56:22.730
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:56:22.731
     dvi:                          {Install FILES}
     inf:                               Opened PNF: 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     inf:                               Opened PNF: 'C:\Windows\INF\mdmcpq.inf' ([strings])
     inf:                               {Install Inf Section [DriverInstall.NTAMD64]}
     inf:                                    CopyFiles=DriverCopyFiles.NTamd64  (arduino uno.inf line 55)
     cpy:                                    Open PnpLockdownPolicy: Err=2. This is OK. Use LockDownPolicyDefault
     flq:                                    QueueSingleCopy...
     flq:                                    Inf     : 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf'
     flq:                                    SourceInf: 'C:\Windows\INF\mdmcpq.inf'
     flq:                                    SourceSection: [sourcedisksfiles]
     flq:                                    Source root path based on SourceInf
     flq:                                    SourceRootPath: 'C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_774523d133de6343'
     flq:                                    {FILE_QUEUE_COPY}
     flq:                                         CopyStyle      - 0x00002000
     flq:                                         {FILE_QUEUE_COPY}
     flq:                                              CopyStyle      - 0x00002000
     flq:                                              SourceRootPath - 'C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd64_neutral_774523d133de6343'
     flq:                                              SourceFilename - 'usbser.sys'
     flq:                                              TargetDirectory- 'C:\Windows\system32\DRIVERS'
     flq:                                              TargetFilename - 'usbser.sys'
     flq:                                              SourceDesc     - 'windows cd'
     flq:                                         {FILE_QUEUE_COPY exit(0x00000000)}
     flq:                                    {FILE_QUEUE_COPY exit(0x00000000)}
     inf:                               {Install Inf Section [DriverInstall.NTAMD64] exit (0x00000000)}
     dvi:                               Processing co-installer registration section [DriverInstall.NTAMD64.CoInstallers].
     inf:                               {Install Inf Section [DriverInstall.NTAMD64.CoInstallers]}
     inf:                               {Install Inf Section [DriverInstall.NTAMD64.CoInstallers] exit (0x00000000)}
     dvi:                               Co-installers registered.
     dvi:                               {Install INTERFACES}
     dvi:                                    Installing section [DriverInstall.NTAMD64.Interfaces]
     dvi:                               {Install INTERFACES exit 00000000}
     dvi:                          {Install FILES exit (0x00000000)}
     dvi:                     Default installer: Exit
     dvi:                {DIF_INSTALLDEVICEFILES - exit(0x00000000)} 17:56:22.764
     ndv:                Pruning file queue...
     dvi:                {_SCAN_FILE_QUEUE}
     flq:                     ScanQ flags=620
     flq:                          SPQ_SCAN_PRUNE_COPY_QUEUE
     flq:                          SPQ_SCAN_FILE_COMPARISON
     flq:                          SPQ_SCAN_ACTIVATE_DRP
     flq:                     ScanQ number of copy nodes=1
     flq:                     File 'C:\Windows\system32\DRIVERS\usbser.sys' pruned from copy.
     sig:                     Using catalog 'C:\Windows\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Microsoft-Windows-Common-Modem-Drivers-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.cat'.
     cpy:                     DrpSetRegFileProt 'C:\Windows\system32\DRIVERS\usbser.sys' Status=0 Class=Inbox Legacy
     flq:                     ScanQ action=200 DoPruning=32
     flq:                     ScanQ end Validity flags=620 CopyNodes=0
     dvi:                {_SCAN_FILE_QUEUE exit(0, 0x00000000)}
     ndv:                Committing file queue...
     flq:                {_commit_file_queue}
     flq:                     CommitQ DelNodes=0 RenNodes=0 CopyNodes=0
     flq:                     CommitQ early exit: No nodes are queued
     flq:                {_commit_file_queue exit OK}
     ndv:                Registering CoInstallers...
     dvi:                {DIF_REGISTER_COINSTALLERS} 17:56:22.846
     dvi:                     Class installer: Enter 17:56:22.848
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:56:22.850
     inf:                          Opened PNF: 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     inf:                          {Install Inf Section [DriverInstall.NTAMD64.CoInstallers]}
     inf:                          {Install Inf Section [DriverInstall.NTAMD64.CoInstallers] exit (0x00000000)}
     dvi:                          Co-installers registered.
     dvi:                     Default installer: Exit
     dvi:                {DIF_REGISTER_COINSTALLERS - exit(0x00000000)} 17:56:22.856
     ndv:                Installing interfaces...
     dvi:                {DIF_INSTALLINTERFACES} 17:56:22.858
     dvi:                     No CoInstallers found
     dvi:                     Class installer: Enter 17:56:22.859
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:56:22.861
     dvi:                          {Install INTERFACES}
     inf:                               Opened PNF: 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     dvi:                               Installing section [DriverInstall.NTAMD64.Interfaces]
     dvi:                          {Install INTERFACES exit 00000000}
     dvi:                     Default installer: Exit
     dvi:                {DIF_INSTALLINTERFACES - exit(0x00000000)} 17:56:22.866
     ndv:                Installing device...
     dvi:                {DIF_INSTALLDEVICE} 17:56:22.867
     dvi:                     Class installer: Enter 17:56:22.868
     inf:                          Opened PNF: 'C:\Windows\INF\oem49.inf' ([strings])
     inf:                          AddReg=DriverInstall.NTamd64.AddReg  (oem49.inf line 56)
     dvi:                          {Install DEVICE}
     inf:                               Opened PNF: 'c:\windows\system32\driverstore\filerepository\arduino uno.inf_amd64_neutral_21f372cd0616c571\arduino uno.inf' ([strings])
     inf:                               Opened PNF: 'C:\Windows\INF\mdmcpq.inf' ([strings])
     dvi:                               Processing Registry/Property directives...
     inf:                               {Install Inf Section [DriverInstall.NTAMD64]}
     inf:                                    AddReg=DriverInstall.NTamd64.AddReg  (arduino uno.inf line 56)
     inf:                               {Install Inf Section [DriverInstall.NTAMD64] exit (0x00000000)}
     inf:                               {Install Inf Section [DriverInstall.NTAMD64.Hw]}
     inf:                                    Empty section
     inf:                               {Install Inf Section [DriverInstall.NTAMD64.Hw] exit (0x00000000)}
     dvi:                               {Writing Device Properties}
     dvi:                                    Provider name=Arduino LLC (http://www.arduino.cc)
     dvi:                                    DriverDate 11/15/2007
     dvi:                                    DriverVersion=5.1.2600.0
     dvi:                                    Class name=Ports
     dvi:                                    Manufacturer=Arduino LLC (http://www.arduino.cc)
     dvi:                                    Matching DeviceID=usb\vid_2341&pid_0001
     dvi:                                    Strong Name=oem49.inf:DeviceList.NTamd64:DriverInstall:5.1.2600.0:usb\vid_2341&pid_0001
     dvi:                               {Writing Device Properties - Complete}
     inf:                               {Install Inf Section [DriverInstall.NTAMD64.Services]}
     inf:                                    AddService=usbser,0x00000002,DriverService.NTamd64  (arduino uno.inf line 67)
     inf:                                    ServiceType=1  (arduino uno.inf line 71)
     inf:                                    StartType=3  (arduino uno.inf line 72)
     inf:                                    ErrorControl=1  (arduino uno.inf line 73)
     inf:                                    ServiceBinary=C:\Windows\system32\DRIVERS\usbser.sys  (arduino uno.inf line 74)
     inf:                                    DisplayName="USB RS-232 Emulation Driver"  (arduino uno.inf line 70)
     dvi:                                    Add Service: Modified existing service 'usbser'.
     inf:                               {Install Inf Section [DriverInstall.NTAMD64.Services] exit(0x00000000)}
     dvi:                               Updated reflected section names for: oem49.inf
     dvi:                          {Install DEVICE exit (0x00000000)}
     dvi:                          Writing common driver property settings.
     dvi:                               DriverDescription=Arduino UNO
     dvi:                               DeviceDisplayName=Arduino UNO
     dvi:                          Install Device: Restarting device. 17:56:25.526
     dvi:                          Install Device: Restarting device completed. 17:56:25.763
     dvi:                     Class installer: Exit
     dvi:                {DIF_INSTALLDEVICE - exit(0x00000000)} 17:56:25.769
     dvi:                {DIF_NEWDEVICEWIZARD_FINISHINSTALL} 17:56:25.773
     dvi:                     Class installer: Enter 17:56:25.779
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:56:25.781
     dvi:                     Default installer: Exit
     dvi:                {DIF_NEWDEVICEWIZARD_FINISHINSTALL - exit(0xe000020e)} 17:56:25.787
     ndv:                Device install status=0x00000000
     ndv:                Performing device install final cleanup...
     ndv:           {Core Device Install - exit(0x00000000)} 17:56:25.793
     dvi:           {DIF_DESTROYPRIVATEDATA} 17:56:25.794
     dvi:                Class installer: Enter 17:56:25.795
     dvi:                Class installer: Exit
     dvi:                Default installer: Enter 17:56:25.796
     dvi:                Default installer: Exit
     dvi:           {DIF_DESTROYPRIVATEDATA - exit(0xe000020e)} 17:56:25.798
     ump:           Server install process exited with code 0x00000000 17:56:25.858
     ump:      {Plug and Play Service: Device Install exit(00000000)}
     dvi:      {DIF_NEWDEVICEWIZARD_FINISHINSTALL} 17:56:25.871
     dvi:           Using exported function 'PortsClassInstaller' in module 'C:\Windows\system32\MsPorts.Dll'.
     dvi:           Class installer == MsPorts.Dll,PortsClassInstaller
     dvi:           No CoInstallers found
     dvi:           Class installer: Enter 17:56:25.875
     dvi:           Class installer: Exit
     dvi:           Default installer: Enter 17:56:25.877
     dvi:           Default installer: Exit
     dvi:      {DIF_NEWDEVICEWIZARD_FINISHINSTALL - exit(0xe000020e)} 17:56:25.878
     ndv: {Update Driver Software Wizard exit(00000000)}
<<<  Section end 2011/03/31 17:56:43.247
<<<  [Exit status: SUCCESS]
[Edit - mod - use code box]
rguindon
 
Posts: 1
Joined: Fri Apr 01, 2011 2:44 pm

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by adafruit_support_bill on Sat Apr 02, 2011 4:51 am

It looks like the driver is installed properly.

TX and RX blink when I try an upload.


If both are blinking, the device is trying to respond. Have you tried a different cable?
User avatar
adafruit_support_bill
 
Posts: 25404
Joined: Sat Feb 07, 2009 9:11 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by mshield on Mon Apr 04, 2011 10:13 pm

This was bloody killing me.
The specific message that I was getting by the time I fixed it was
"avrdude: stk500_recv(): programmer is not responding"

Which I fixed by setting the baud rate to 57600 with
-b 57600

Originally I was getting the
"avrdude: stk500_getsync(): not in sync: resp=0x00"

But unfortunately I've lost the steps that I went through to get from the getsync() error to the recv() error.
Still I thought I'd add this here in case the baud rate thing makes a difference...
mshield
 
Posts: 1
Joined: Mon Apr 04, 2011 10:01 pm

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by DanTheCarver on Sun Sep 11, 2011 1:00 am

I was having the same problem although in my case, the message was slightly different:
avrdude: stk500_getsync(): not in sync: resp=0x30 <-- 30 instead of 00.
Also, the TX and RX LEDs were never coming on.
I looked through many forums and tried all the suggestions, except loading a new copy of Optiboot.
I then played with the COM port and it fixed the problem!
I was using COM3 which was the default. As far as I knew, I did not have anything using COM3 but then I remembered playing with a USB to Serial card about a year ago. So for the heck of it, I changed COM3 to COM9 and it worked! YEAH!!!
Here's what I did:
(I am on Vista) Control panel - System - Device Manager - Ports - Arduino - Properties - Port Settings - Advanced and changed COM Port Number to COM9. I OK'ed my way out of the properties and then ran the IDE. I went to Tools - Serial Port and set it to COM9. When I did that, it listed COM9 but there was not a check mark which I had seen when I was using COM 3. So I clicked on COM9 and the check mark was added (dunno what that means). I loaded the blink example (File - Examples - 1.Basics - Blink), uploaded it and it ran smooth as whistle!

So, my suggestion is try different COM ports, from 3-9 (I found a note saying Aruduino doesn't like ports above 9).
DanTheCarver
 
Posts: 2
Joined: Sun Sep 11, 2011 12:07 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by alexandrers on Mon Jun 18, 2012 8:20 am

I was having a similar problem, reinstalled Arduino and so my win7 x32 created a new com port(12), and it worked with my arduino, i just don't know why my old com port disappeared
alexandrers
 
Posts: 1
Joined: Mon Jun 18, 2012 8:16 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by jeffrese on Tue Jul 17, 2012 8:01 pm

I had the same error, changing from port com3 to com9 in the device manager and the IDE worked for me. :D
jeffrese
 
Posts: 1
Joined: Tue Jul 17, 2012 8:00 pm

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by adafruit_support_bill on Tue Jul 17, 2012 8:15 pm

Yes, this happens in Windows from time to time. The OS decides that it needs to assign a new COM port. :?
User avatar
adafruit_support_bill
 
Posts: 25404
Joined: Sat Feb 07, 2009 9:11 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by skub on Thu Aug 02, 2012 6:52 pm

OP, any reason you're using the Arduino 0022 release and not the more current version 1.0.1?
skub
 
Posts: 26
Joined: Sun Mar 11, 2012 9:55 pm

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by knuckles on Sun Aug 19, 2012 12:15 pm

i am trying to get round this hitch ,tried numerous ports and no dice, i connected the RX to the TX on the USB device and it appears to be ok so the port must be working ,but the same error message comes up
knuckles
 
Posts: 29
Joined: Wed Aug 15, 2012 11:29 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by adafruit_support_bill on Sun Aug 19, 2012 1:35 pm

i connected the RX to the TX on the USB device

What exactly did you you connect? Are you talking about pins on the 16U4?
User avatar
adafruit_support_bill
 
Posts: 25404
Joined: Sat Feb 07, 2009 9:11 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by knuckles on Mon Aug 20, 2012 10:40 am

loop back test on the usb device ,it echos keypresses in the monitor

usb device has a silab chip
knuckles
 
Posts: 29
Joined: Wed Aug 15, 2012 11:29 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by knuckles on Mon Aug 20, 2012 11:28 am

tried it with a uno a xino and a pro micro ,same error message ..
knuckles
 
Posts: 29
Joined: Wed Aug 15, 2012 11:29 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by wrmanis on Tue Dec 04, 2012 10:56 pm

So, I had this error on the OSEPP Uno R3 plus. I solved it by selecting Duemilanove w/ ATmega328 as my board, even though it is CLEARLY labled the Uno. Give it a shot!
wrmanis
 
Posts: 1
Joined: Tue Dec 04, 2012 10:54 pm

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by adafruit_support_bill on Wed Dec 05, 2012 6:05 am

I had this error on the OSEPP Uno R3 plus. I solved it by selecting Duemilanove w/ ATmega328 as my board, even though it is CLEARLY labled the Uno.

The Board Type is determined by the bootloader burned into the chip. Any UNO will behave like a Duemilanove if you put a Duemilanove compatible bootloader on it. I have a couple with 'non-standard' bootloaders and I label them with tape to avoid confusion.
User avatar
adafruit_support_bill
 
Posts: 25404
Joined: Sat Feb 07, 2009 9:11 am

Re: programs not load avrdude: stk500_getsync(): not in sync: resp=0x00

by mahadevan on Tue Jun 18, 2013 1:59 pm

I am not sure this helps your case. But I had similar error and solved it by pressing the 'reset' button before 'avrdude' writes to the Arduino. More info is at http://mahadevangorti.blogspot.in/2013/ ... -home.html
mahadevan
 
Posts: 1
Joined: Tue Jun 18, 2013 1:55 pm