Arduino Uno Rev 3 appearing as 'unknown device'

by Dr Rick on Mon Dec 10, 2012 12:51 pm

I received the Adafruit ARDX - v1.3 Experimentation Kit for Arduino (Uno R3) and when plugging into two different computers (both Windows 7 x64) the device powers up (green power LED turns on, and the L light flashes continuously, TX/RX never light up), but it is not recognized as an Arduino Uno, it is listed as 'Unknown device' under 'Other devices'. Attempts to install the drivers fail because the device isn't recognized.

Any suggestions?
Dr Rick
 
Posts: 2
Joined: Tue Dec 04, 2012 12:31 pm

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by adafruit_support_bill on Mon Dec 10, 2012 12:57 pm

Go into DeviceManager and right click on the unknown device.
Uninstall any driver for that device.
Then install the correct driver. Use the "browse" option to select the driver from the "drivers" folder of your Arduino install.
User avatar
adafruit_support_bill
 
Posts: 25511
Joined: Sat Feb 07, 2009 9:11 am

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by Dr Rick on Tue Dec 11, 2012 12:52 am

Thanks! I uninstalled, then installed the UNO R3 driver via hdwwiz, and after a few USB connect/disconnect cycles, I got it to finally recognize the device.
Dr Rick
 
Posts: 2
Joined: Tue Dec 04, 2012 12:31 pm

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by amose on Sat Feb 16, 2013 2:40 pm

I'm having the same problem. I have uninstalled the "unknown device", but I do not know how to install from the downloaded zip file. I tried using hdwwiz, but I was not sure how to use it. I selected "Ports (COM & LPT)", then "Communications Port". It never gave me an opportunity to install driver from the unzipped directory I downloaded. Please provide me with step-by-step details.
amose
 
Posts: 2
Joined: Fri Feb 08, 2013 5:11 pm

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by adafruit_support_bill on Sat Feb 16, 2013 3:09 pm

Make sure you have the correct device in device manager. It should disappear when you unplug it and re-appear when you plug it back in.

When you locate the device, first uninstall the driver if necessary.

Then, select "update driver" and use the "browse" option.

Navigate to your unzipped Arduino install directory and find the "drivers" folder.

It will not show any available drivers, but select that folder anyway. (Do not select any of the subfolders!).

If it warns you about an unsigned driver, tell it to install anyway.
User avatar
adafruit_support_bill
 
Posts: 25511
Joined: Sat Feb 07, 2009 9:11 am

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by adafruit_support_rick on Sat Feb 16, 2013 3:13 pm

Go back into Device Manager and right-click on the Uno. It may show up under 'Other Devices', rather than under comm ports. If you're not sure, unplug and re-plug the Uno's USB cable while watching the Device Manager window. Look for a device that disappears and re-appears.

When you right-click, select 'Update Driver...'. This will bring up the driver update wizard, which is exactly the same as the Found New Hardware wizard. Follow the normal instructions to navigate to the unzipped driver directory.

Note: you won't see the .inf driver file when you're in the wizard. Just navigate and select the folder which contains the driver file.

Oh...um...what adafruit_support said...
Last edited by adafruit_support_rick on Sat Feb 16, 2013 3:14 pm, edited 1 time in total.
Reason: lost the race to post the answer first!!
User avatar
adafruit_support_rick
 
Posts: 8569
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by amose on Sat Feb 16, 2013 4:56 pm

Thanks for the responses. I also found a nice explanation at http://arduino.cc/forum/index.php?topic=104698.0.

My main problem was that I opened the .zip file, but had not actually extracted it. So the Arduino directories were not actually visible when attempting to update the driver. Once I fixed that, everything was ok.

Thanks for the help.
amose
 
Posts: 2
Joined: Fri Feb 08, 2013 5:11 pm

Re: Arduino Uno Rev 3 appearing as 'unknown device'

by adafruit_support_rick on Sun Feb 17, 2013 12:18 pm

I've always had mixed feelings about that 'feature' of Windows Explorer. I like that you can go through zip files without extracting them, but that makes it easy to forget that you've never actually done the extraction .
User avatar
adafruit_support_rick
 
Posts: 8569
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY