Cannot upload sketches to Menta

by segfault on Sat Feb 23, 2013 10:05 am

Hi, I soldered together a Menta according to the instructions. The solder joints all look good. When I plug in external or USB power, the green power LED lights up. But when I press the reset button, nothing happens. (I understand from the instructions that the red LED should flash.) When I try to upload a sketch, I get the following error:

avrdude: stk500_recv(): programmer is not responding

How should I go about troubleshooting the device?
segfault
 
Posts: 4
Joined: Sat Feb 23, 2013 9:59 am

Re: Cannot upload sketches to Menta

by adafruit_support_rick on Sat Feb 23, 2013 1:47 pm

Are you attempting to use this with the Arduino IDE? How are you connecting to the menta? FTDI friend/FTDI cable? Have you selected the correct serial port in the IDE?

Post clear, detailed, focused pictures of both sides of the Menta board.
User avatar
adafruit_support_rick
 
Posts: 8492
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Cannot upload sketches to Menta

by segfault on Sat Feb 23, 2013 2:12 pm

Thanks for your hints!

- I'm using the Arduino IDE.
- I'm connecting with an FTDI cable
- The correct serial port is set.

My sister is making hi-res pictures of the board, I'll post them as soon as I get them. The solder joints look perfectly OK to me.
segfault
 
Posts: 4
Joined: Sat Feb 23, 2013 9:59 am

Re: Cannot upload sketches to Menta

by segfault on Sat Feb 23, 2013 2:42 pm

Here are two pictures of the board:

menta_bottom.jpg
menta_bottom.jpg (496.87 KiB) Viewed 541 times


menta_top.jpg
menta_top.jpg (473.54 KiB) Viewed 541 times
segfault
 
Posts: 4
Joined: Sat Feb 23, 2013 9:59 am

Re: Cannot upload sketches to Menta

by adafruit_support_rick on Sat Feb 23, 2013 2:57 pm

Hmmm ... that all looks good.
Try the procedure outlined here:
http://joekanedesign.com/blog/2012/11/a ... -solution/
User avatar
adafruit_support_rick
 
Posts: 8492
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Cannot upload sketches to Menta

by segfault on Sun Feb 24, 2013 8:21 am

Tried it a couple of times, didn't work :( The red LED blinks once, almost exactly when the stk500_recv() error message appears on screen. Any more ideas?
segfault
 
Posts: 4
Joined: Sat Feb 23, 2013 9:59 am

Re: Cannot upload sketches to Menta

by adafruit_support_bill on Sun Feb 24, 2013 8:29 am

If the red led is not flashing on reset, you may have a bad (or missing) boot loader (the assembly looks fine). Contact support@adafruit.com with a link to this thread and ask for a replacement Menta processor.
User avatar
adafruit_support_bill
 
Posts: 25402
Joined: Sat Feb 07, 2009 9:11 am