Data logger shield no longer recognizes uSD card
Moderators: adafruit_support_bill, adafruit

Data logger shield no longer recognizes uSD card

by oldfox on Sat Mar 30, 2013 2:29 pm

I have a MEGA2560R3 with factory assembled data logging shield, using an Adafruit supplied microSD car. It was working just fine. Now the problem is that the SD card won't initialize. I have tried the following:
2 different cards in 2 different SD adapters
SD library example sketches... DumpFile and CardInfo. Neither will recognize the card. Reports "card not initialized" or "card not present". Have checked everything. Downloaded SD library. Deleted old SD library from the sketchbook/libraries folder. The SD library no longer was anyplace on my computer. Reinstalled the SD library into sketchbook/libraries folder. I downloaded the SD lib from the link to github on the "data logging shield" tutorial page.
I also tried one my own sketches which would previuosly read either card just fine. Same problem.
I am running Windows XP SP3 on my computer.
oldfox
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by franklin97355 on Sat Mar 30, 2013 3:29 pm

Since you have tried two different cards in two different adapters I would say it is not the card. Have you tried any demo/test code or is this a program you wrote yourself? You might try formatting the card on your PC and testing it there and then see if it works on the Arduino.
User avatar
franklin97355
 
Posts: 4557
Joined: Mon Apr 21, 2008 1:33 pm

Re: Data logger shield no longer recognizes uSD card

by oldfox on Sat Mar 30, 2013 3:51 pm

As noted, I tried 2 cards in each and every scenario. I tried 2 different Adafruit example (demo) sketches, "CardInfo" and "DataDump". I also formatted both cards. I can read and write to either card in a 3rd card reader, from the computer. I'm stumped.
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by adafruit_support_rick on Sat Mar 30, 2013 4:07 pm

Could be that a marginal solder connection on one of the headers cracked after a bit of use. Post clear pictures of the solders and we'll have a look.
User avatar
adafruit_support_rick
 
Posts: 11681
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Data logger shield no longer recognizes uSD card

by oldfox on Sat Mar 30, 2013 5:25 pm

Well, I tried to take pictures like you requested, but they are just blurry to show the detail you would need to see. I'm *not* a photographer. I *am* a 50+ year, US Navy trained electronics tech.
Tech as in "fix other peoples broken stuff". So I just went over all 28 interface pins with the iron again and gave everything a good supereye. (magnifying glass) All pins have the proper concave solder fillet. No cold joints. I then tried the setup again. No change. The card is still not recognized.
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by adafruit_support_rick on Sat Mar 30, 2013 8:54 pm

I learned long ago not to mess with Navy ETs. Email support@adafruit.com with a link to this thread and ask for a replacement.
User avatar
adafruit_support_rick
 
Posts: 11681
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Data logger shield no longer recognizes uSD card

by oldfox on Sat Mar 30, 2013 9:02 pm

Thank you . I'll follow through with the replacement. btw, ETs are harmeless :lol:
Were you a BM?
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by oldfox on Sat Mar 30, 2013 9:10 pm

Oh, another btw. Would it be possible to get the schematic of the data logging shield updated? I suspect that the one in the tutorial is for the old "kit" board. The schema shows a "quad" gate. The one on the factory assembled board is an SMD 16 pin. A "hex" gate. That's where I gave up the idea of troubleshooting it myself.
Thanks again.
-oldfox-
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by adafruit_support_rick on Sat Mar 30, 2013 9:31 pm

oldfox wrote:Thank you . I'll follow through with the replacement. btw, ETs are harmeless
Were you a BM?

Well, I'm a dumb s**t, if that's what you mean. :lol:

No, I only worked with a retired ET or two at my old job. One of them did bull-riding as a casual hobby. I never met a better HW troubleshooter than that guy, and I never messed with him, either :wink:

The product page is promising that the updated schematic will be uploaded 'soon' - I'll see if I can get something more definite on that.
User avatar
adafruit_support_rick
 
Posts: 11681
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Data logger shield no longer recognizes uSD card

by oldfox on Sat Mar 30, 2013 9:39 pm

BM = Boatswains Mate. Your Avatar looks like a BM or a cook. :D
Thanks for pursuing the update issue. And you have to remember, if we couldn't fix it, there was no place to run. Got your seven league boots?
I was stationed in Spain for 3 years. I did bull-fighting for a "casual hobby".
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by adafruit_support_rick on Sat Mar 30, 2013 10:01 pm

oldfox wrote:BM = Boatswains Mate. Your Avatar looks like a BM or a cook.

That's Ralph Kramden! It's the icon from a system I wrote long ago - called DriverBlock.
oldfox wrote:I was stationed in Spain for 3 years. I did bull-fighting for a "casual hobby".

See? Why I don't mess with ETs.
User avatar
adafruit_support_rick
 
Posts: 11681
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Data logger shield no longer recognizes uSD card

by adafruit_support_rick on Sun Mar 31, 2013 9:44 am

The word is that the new data logger schematic is on the to-do list. No ETA...
User avatar
adafruit_support_rick
 
Posts: 11681
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Data logger shield no longer recognizes uSD card

by oldfox on Sun Mar 31, 2013 9:51 am

You have to work on Easter? Thanks for the schematic update. I'll keep my eyes open for it.
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm

Re: Data logger shield no longer recognizes uSD card

by adafruit_support_rick on Sun Mar 31, 2013 10:29 am

oldfox wrote:You have to work on Easter?

Yep - Phil keeps us chained in adafruit's cellar. We live for Friday evenings, when they toss us the leftover pizza crusts from the weekly State Of The Fruit meetings.

It's not quite so cushy here as in the Navy.
User avatar
adafruit_support_rick
 
Posts: 11681
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Data logger shield no longer recognizes uSD card

by oldfox on Tue Apr 02, 2013 4:20 pm

I don't know if this info will be of interest to anyone or not. Without a proper schematic I wasn't going to tackle the task of researching the boards every chip datasheet to get the proper pinouts.
So on a whim I put a meter on the CS pin (10 on the MEGA2560R3). With the MEGA at idle (not running a sketch) I measured +4.84V. When the sketch (CardInfo) started to run the level dropped to +0.012V. So my question is this:
Is the CS active high or low?
-oldfox-
"If it ain't broke, fix it 'til it is."
oldfox
 
Posts: 41
Joined: Wed Jan 23, 2013 3:18 pm