Arduino UNO after pc reboot sketch is lost

by timmaeh on Fri Nov 09, 2012 6:54 pm

Hi guys,

i got my functional Adalight here, iam using this with boblight and xbmc. Everytime i restart my htpc or just shut it down and start it the next day i had to reupload the adalight sketch again. After this reupload all works fine.

Then i shut my pc down, next day i wanna watch a movie with adalight, nothing works until i reupload the sketch.

My sketch: http://pastebin.com/wuuLCvnr

Before i restart my pc
Image

After the reboot but before i reupload the pde file
Image

Can somebody help me out?
Last edited by timmaeh on Fri Nov 09, 2012 11:03 pm, edited 1 time in total.
timmaeh
 
Posts: 2
Joined: Fri Nov 09, 2012 6:50 pm

Re: Arduino UNO after pc reboot sketch is lost

by tldr on Fri Nov 09, 2012 10:48 pm

a little googling leads me to believe that your problem is not on the arduino, but that boblight is not properly initializing the com port. uploading the sketch takes care of that. to satisfy yourself that this is true try running the arduino ide and opening the serial monitor, but don't upload the sketch. close the ide and boblight should then be able to talk to the arduino.

sorry, but i can't offer a solution, just help you narrow your search for the problem.
"If I had known it was harmless, I would have killed it myself." - Phillip K. Dick, A Scanner Darkly
User avatar
tldr
 
Posts: 466
Joined: Thu Aug 30, 2012 12:34 am

Re: Arduino UNO after pc reboot sketch is lost

by timmaeh on Fri Nov 09, 2012 10:55 pm

Hey :),

i just made a little workaround for this problem.

I made a batchfile wich opens the arduino ide so the port is initializied. Works for now.

Code: Select all | TOGGLE FULL SIZE
start "arduino" D:\Arduino-1.02\arduino.exe -c

TIMEOUT /T 1

taskkill /im arduino.exe -f

TIMEOUT /T 1

start "boblightd" /MIN C:\boblightd\boblightd.exe -c c:\boblightd\boblight.conf -f


maybe this helps somebody someday
timmaeh
 
Posts: 2
Joined: Fri Nov 09, 2012 6:50 pm