The new Raspberry Pi B Model B+ is here - Pick one up in the store and check our detailed guide!

Arduino won't recieve USB power, only 9v

by dinz on Thu Mar 28, 2013 5:07 pm

I've had my arduino for a short while now, and everything was working perfectly until today. My usb will no longer power or connect to my arduino, but my 9v battery pack can still power it. I'm not sure what's causing it or if it was shorted out, but the only thing that happened beforehand which caused it to not start up was me wiring a switch circuit. normally i wire the 5v pin to one side of the button, 10k resistor to the other side, and the ground on the end of the resisitor. I put the jumper to get the signal to the digital pin on the pin that the resistor is connected to. Today i forgot to put the resistor in, and the first thing i noticed was there was no power to the board when i plugged it in.

I'm sort of worried that i shorted something, but i don't know what. The 5v and ground were separated by a switch, and the jumper going to digital pin 7 as a signal carried no significant current. I've tried taking everything off the board, including my motorshield that i got from adafruit, but absolutely nothing is working. Is there some sort of trick that i'm not aware of, or did i short something important? :shock:
dinz
 
Posts: 1
Joined: Thu Mar 28, 2013 4:53 pm

Re: Arduino won't recieve USB power, only 9v

by adafruit_support_bill on Thu Mar 28, 2013 5:10 pm

Sounds like you may have overloaded the USB port. Typically, they shutdown when overloaded (>500mA) and come back later. It can be a while (10-15 minutes or more) but they usually come back.
User avatar
adafruit_support_bill
 
Posts: 27992
Joined: Sat Feb 07, 2009 9:11 am