The hunt for COM ports with Micro and LED Belt.
Moderators: adafruit_support_bill, adafruit

The hunt for COM ports with Micro and LED Belt.

by chrisjx on Fri May 10, 2013 3:53 am

Having awkward behavior and I'm guessing I'm not the first... ;}

Windows 7. Arduino Micro.

To upload code, seems you have to push the reset button at about the same time as you click the compile/load button. Sometimes it works; sometime not...

I plug in the Arduino Micro and I see, in Device Manager, Arduino Micro bootloader, COM35, become active; then it goes away and then I see Arduino Leonardo, COM40, appear.

I go into Arduino IDE 1.0.4 and select Arduino Micro as the board. I go into select serial port and all I see are COM1, COM3. Sometimes I'll see the COM40 appear, but usually not.

In order to upload to COM35, the Arduino Micro boot-loader, I have to push the Micro's reset button and quickly select COM35 from the Serial Port menu while it is active. That is the only way I know of to associate the Micro with COM35. It goes away as soon as the Micro resets (leaving me with COM40 in Device Manager).

I can see COM35 in the bottom right status bar of the Arduino IDE even though I can't see it in the Serial Port menu.

The main gotcha/show stopper is that I'm not sure how to access the serial monitor. If I can't access COM35, because it went away, and if COM40 doesn't show up in the Serial Port menu... what's a poor boy to do?

I know the port numbers can vary from machine to machine; right now I'm in the 30s and 40s range.

Occasionally the IDE will throw an error that the port is already in use. Sometimes restarting the IDE will fix that, but not always; besides it's very frustrating... Seems I'm reseting and trying to find an ever elusive port more than I am writing and testing code.

I see the same behavior even when using a powered USB hub.

My ultimate goal is to get a pulse sensor, amped, hooked up and to display the pulses using the Arduino Micro and a mashup of the belt code and the pulse sensor code. Have made all the changes described for Atmega32u4.

http://pulsesensor.myshopify.com/pages/ ... ino-v1dot1

Any help, tip, tricks to make the code loading process more reliable would be appreciated.

Thanks in advance,
Chris.
fun with Wireless Sensor Networks...
Gateway: Raspberry Pi (formerly wifi routers with OpenWRT), Python -> Cosm.com, ThingSpeak.com, Open.Sen.se, etc.
Hardware: Tweet-A-Watt, (+ temp, ldr/light, gas, fsr, etc.)
My notes at: http://TinajaLabs.com
User avatar
chrisjx
 
Posts: 73
Joined: Mon Aug 09, 2010 5:17 am
Location: north berkeley