Arduino Micro driver on XP

by HFarms on Tue Oct 29, 2013 8:26 pm

I'm having trouble getting my new Micro recognized under XP 32 bit SP3.
The "new hardware wizard" is looking for ATm32U4DFU. I've given it the Old_Arduino_Drivers unzipped from Arduino IDE v1.0.5, but it still isn't happy.
My Unos work fine.
Any ideas? [aside from "upgrade your OS" :)]
My only idea right now is that maybe the USB PID has changed. From the Arduino Micro.inf file...
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_0037
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_8037&MI_00

Thanks,
Kent
HFarms
 
Posts: 4
Joined: Tue Oct 29, 2013 8:12 pm

Re: Arduino Micro driver on XP

by thefatmoop on Tue Oct 29, 2013 11:57 pm

Use the leonardo drivers, not the uno.
User avatar
thefatmoop
 
Posts: 329
Joined: Tue Aug 19, 2008 3:36 pm

Re: Arduino Micro driver on XP

by HFarms on Wed Oct 30, 2013 10:01 pm

Leonardo driver doesn't work, either.
HFarms
 
Posts: 4
Joined: Tue Oct 29, 2013 8:12 pm

Re: Arduino Micro driver on XP

by franklin97355 on Wed Oct 30, 2013 10:49 pm

Try removing the usb devices, uninstall the IDE, reboot, install the IDE, then plug in the micro. See what happens.
User avatar
franklin97355
 
Posts: 3994
Joined: Mon Apr 21, 2008 1:33 pm

Re: Arduino Micro driver on XP

by HFarms on Fri Nov 01, 2013 2:07 pm

I did the uninstall/reinstall and same problem. I've also installed the Arduino 1.0.5 IDE on a Windows 7 machine that had never had it and still have the same problem.
HFarms
 
Posts: 4
Joined: Tue Oct 29, 2013 8:12 pm

Re: Arduino Micro driver on XP

by adafruit_support_rick on Sat Nov 02, 2013 2:18 am

What does the Micro appear as in Device Manager?
User avatar
adafruit_support_rick
 
Posts: 10959
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Arduino Micro driver on XP

by HFarms on Sat Nov 02, 2013 7:58 am

ATm32U4DFU under "Other devices"
HFarms
 
Posts: 4
Joined: Tue Oct 29, 2013 8:12 pm

Re: Arduino Micro driver on XP

by adafruit on Sat Nov 02, 2013 2:21 pm

weird! lets get you a replacement - sounds like somehow the bootloader didnt get put on there (?) - email support@adafruit.com with a link to this thread for a new micro
User avatar
adafruit
 
Posts: 11647
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc