Widget Issues

by bcook65 on Mon Sep 20, 2010 1:39 am

Built my ybox2 and got it running pretty much with no problems with the weather widget..

loaded the alarm widget.. seemed to be working ok but had some issues when setting the alarm

loaded the twitwidget.. But it only displays server info etc.. Tried downloading the twitxmlwidget.spin, found a spin compiler, i think, and had to download a whole bunch of other spin files to make it compile.. but still get the same display

downloaded hackish hangman and it seems to work ok

downloaded a web 2.0 dashboard widget, I guess it is the info(weather) widget pointing somewhere else, but it gives a whole screen full of errors and syntax errors.. Dont have a clue what to do to fix that

tried to go back and re install the weather widget that came with the board, it loads to it, but when i reset the board, appears the ybox2 just shuts down. Have to remove power and restart.. try to load stage 2 and it shuts down.. How do I get my weather widget back?????

this is such a cool kit and wasn't too cheap either.. wish there were more functional widgets available in one place, especially the binary files. The spin tool isnt to friendly if you dont know how to use it or what files you have to have to make a specific binary file
BCook65
Electricity is your friend and your friend needs a hug... :O
bcook65
 
Posts: 83
Joined: Sat Apr 03, 2010 12:25 pm

Re: Widget Issues

by bcook65 on Wed Sep 22, 2010 11:11 pm

no one? Is the ybox just gonna fade away?
BCook65
Electricity is your friend and your friend needs a hug... :O
bcook65
 
Posts: 83
Joined: Sat Apr 03, 2010 12:25 pm

Re: Widget Issues

by adafruit on Fri Oct 01, 2010 12:14 pm

we're not sure what the problem is, twitter changed everthing (again) and its not going to be possible to keep up with their new protocols. can you load any widgets?
User avatar
adafruit
 
Posts: 11643
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

Re: Widget Issues

by bcook65 on Sat Oct 02, 2010 11:41 pm

adafruit wrote:we're not sure what the problem is, twitter changed everthing (again) and its not going to be possible to keep up with their new protocols. can you load any widgets?


yeah.. I was able to load the hangman one and it worked..

the clock worked although I got an error on the alarm

the infowidget(weather) that was first loaded on when I first built the ybox worked(i think it had the ladyada.net or something as the host, but when I went back and tried to re load it again after trying other widgets, it didnt work, but this time it had some propserv host and some other server address.. I cannot seem to locate the original infowidget with the ladyada.net host so am not able to reload it at this point.
I had tried to load web 2.0 dashboard widget, I had found but never got it to work

i got the twitwidget to work by using the modified files posted on the forums and using twitter.com as host and 128.121.146.100 as the server address.. I can follow almost anything (currently following /coasttocoastam) but on occasion I get an error 6 but it corrects itself apparently after a few cycles until it errors again, so on and so forth.. its bearable as I dont just sit in front of it and wait for errors to come and go.

I really like the project seems to have a lot of potential.. Wish there were a few more widgets around for it or that I knew and understood spin enough to try my own.

thanks for the reply :)
BCook65
Electricity is your friend and your friend needs a hug... :O
bcook65
 
Posts: 83
Joined: Sat Apr 03, 2010 12:25 pm

Re: Widget Issues

by adafruit on Sun Oct 03, 2010 6:07 pm

try using the ladyada.net ip address - we posted this in the forums somewhere (we think)
User avatar
adafruit
 
Posts: 11643
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

Re: Widget Issues

by bcook65 on Sun Oct 03, 2010 9:30 pm

adafruit wrote:try using the ladyada.net ip address - we posted this in the forums somewhere (we think)


Doh !.. can you think a little more clearly? them forums is a big place... :) I'll take a few jabs at it after I grab a cognac.. :-D
BCook65
Electricity is your friend and your friend needs a hug... :O
bcook65
 
Posts: 83
Joined: Sat Apr 03, 2010 12:25 pm

Re: Widget Issues

by bcook65 on Sun Oct 03, 2010 9:37 pm

think I found it.. is this this correct below?

ive copied infowidget to my server
you can now use
settings.setString(settings#SERVER_HOST,string("www.ladyada.net"))
settings.setData(settings#SERVER_IPv4_ADDR,string(207,58,139,246),4)
settings.setWord(settings#SERVER_IPv4_PORT,80)
settings.setString(settings#SERVER_PATH,string("/infowidget/?zipcode=95008"))
it shouldnt move, like, ever


This is what I am currently using and it seems to work too
host: twitter.com
user: /coasttocoastam (or whatever)
address: 128.121.146.100
BCook65
Electricity is your friend and your friend needs a hug... :O
bcook65
 
Posts: 83
Joined: Sat Apr 03, 2010 12:25 pm