The new Raspberry Pi B Model B+ is here - Pick one up in the store and check our detailed guide!

Noisy Stereo problem with the MAX98306 3.7W

by Nramond on Wed Nov 14, 2012 5:01 am

Hi again,
Maybe it's not my day, but I'm beginning to think I have not been lucky with my last shipment.
I'm using right now the stereo amplifier 3.7W and It seems to be a little NEW problem with the L OUT.
I tried different configuration but it's always the same, the L OUT is very noisy and has low level output.
My speakers are fine as I have tested each of them separatly.
I checked a lot of batteries and power and it didn't change anything.
Solder seems to be ok and wire too (I'm not bad at this I think)

Before using it, I found something strange on the chip, maybe you can tell me if it can be this :
Thank you.
Attachments
1211141042_0.jpg
1211141042_0.jpg (216.11 KiB) Viewed 458 times
Nramond
 
Posts: 11
Joined: Sat Oct 06, 2012 4:21 pm

Re: Noisy Stereo problem with the MAX98306 3.7W

by adafruit_support_bill on Wed Nov 14, 2012 4:04 pm

Can't tell from the photo what is on the face of the chip. Stray flux maybe? The solder on the left channel input pins looks OK. Can't see the output pins from this angle. Can you post a photo showing the soldering on the back of the board too?

Have you tried swapping left & right inputs? Dies the problem follow the source, or remain on the left channel?
User avatar
adafruit_support_bill
 
Posts: 28034
Joined: Sat Feb 07, 2009 9:11 am

Re: Noisy Stereo problem with the MAX98306 3.7W

by Nramond on Thu Nov 15, 2012 4:19 am

Thank you for taking my problem in consideration.

Yes, I tried different configuration. ( speaker left to speaker right and source left to source right) and it's always the same, the L out is definitly not powered and noisy.
Speakers have been tested, I have three wave shield working good, I think I should have bought at least two stereo amplifier for testing damn it.

As you requested, I have taken some photos of my solder :

1211151010_1.jpg
1211151010_1.jpg (167.06 KiB) Viewed 422 times


1211150942_0.jpg
1211150942_0.jpg (145.58 KiB) Viewed 422 times


Here you have a better view of everything, in case you think this the mess here, I want to add I have tested everything here! :)
Attachments
vue d'ensemble.jpg
vue d'ensemble.jpg (861.65 KiB) Viewed 422 times
Nramond
 
Posts: 11
Joined: Sat Oct 06, 2012 4:21 pm

Re: Noisy Stereo problem with the MAX98306 3.7W

by adafruit_support_bill on Thu Nov 15, 2012 6:20 am

OK then, Contact support@adafruit.com with a link to this thread and ask for a replacement amplifier.
User avatar
adafruit_support_bill
 
Posts: 28034
Joined: Sat Feb 07, 2009 9:11 am

Re: Noisy Stereo problem with the MAX98306 3.7W

by Nramond on Thu Nov 15, 2012 7:30 am

Thank you! :wink:
Nramond
 
Posts: 11
Joined: Sat Oct 06, 2012 4:21 pm