PN532 RFID/NFC Shield - "Didn't find PN53x board."

by dp1924 on Sat Dec 22, 2012 8:43 pm

Hello,

I recently purchased the RFID/NFC Shield for Arduino and I am having the same problems as a few other people here. I keep getting the "Didn't find PN53x board." message when I try to use the shield. I have tried all the sketches from the Adafruit_PN532 library and the same thing happens. When I reset, the red BUSY light turns off for a second and then stays on continuously and the green PWR light remains on. It is connected to an Arduino Uno R3 using stackable headers. I believe my soldering was fine but I will post some pictures. I may just have a defective board, but please let me know if anything looks wrong. Thank you!
Attachments
2012-12-22 18.19.02.jpg
2012-12-22 18.19.02.jpg (909.32 KiB) Viewed 817 times
2012-12-22 18.18.37.jpg
2012-12-22 18.18.37.jpg (772.74 KiB) Viewed 817 times
2012-12-22 18.15.23.jpg
2012-12-22 18.15.23.jpg (922.83 KiB) Viewed 817 times
dp1924
 
Posts: 3
Joined: Sat Dec 22, 2012 8:03 pm

Re: PN532 RFID/NFC Shield - "Didn't find PN53x board."

by dp1924 on Sat Dec 22, 2012 8:44 pm

Two more pictures:
Attachments
2012-12-22 18.16.01.jpg
2012-12-22 18.16.01.jpg (856.91 KiB) Viewed 815 times
2012-12-22 18.19.16.jpg
2012-12-22 18.19.16.jpg (865.17 KiB) Viewed 816 times
dp1924
 
Posts: 3
Joined: Sat Dec 22, 2012 8:03 pm

Re: PN532 RFID/NFC Shield - "Didn't find PN53x board."

by adafruit_support_rick on Sun Dec 23, 2012 12:28 pm

Sorry for the trouble.

Is anything else connected, or is it only the Uno and the RFID shield?

Are you using the I2C version of the library?
User avatar
adafruit_support_rick
 
Posts: 10761
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: PN532 RFID/NFC Shield - "Didn't find PN53x board."

by dp1924 on Sun Dec 23, 2012 5:38 pm

I tried the Adafruit_NFCShield_I2C library and it worked! Thank you for the quick reply. I was using the Adafruit_PN532 library before, which I guess is different.
dp1924
 
Posts: 3
Joined: Sat Dec 22, 2012 8:03 pm