Do waveshield and CC3000 wifi shield work on the same arduin

by local_dani_21 on Tue Oct 29, 2013 2:27 pm

Hi

I ran into problems trying to use your waveshield together with a wifly from sparkfun.com (https://www.sparkfun.com/products/9954). I need an audio-arduino with a wificonnection, so my question:

Do you know whether your Adafruit CC3000 WiFi Shield with Onboard Ceramic Antenna works together with a waveshield.

Thank you for letting me know.

Dani
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland

Re: Do waveshield and CC3000 wifi shield work on the same ar

by adafruit_support_mike on Tue Oct 29, 2013 5:28 pm

Both shields use some of the same pins by default, but we've designed them so you can reconnect the signals if necessary.

The CC3000 shield has a row of holes over by digital pins 8-13 with all the signal names. If necessary, you can cut the traces to the default Arduino pins and move the signals to other pins that are free.
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 8632
Joined: Thu Feb 11, 2010 1:51 pm

Re: Do waveshield and CC3000 wifi shield work on the same ar

by local_dani_21 on Wed Oct 30, 2013 3:00 am

Has anyone actually tried running the two boards at the same time on the same arduino?

I'm asking because theoretically a waveshield (run with SPI-pins 11-13 and SS on pin 9) should work together with a wiflyshield (https://www.sparkfun.com/products/9954) that is run from SPI-standard-pins (10-13). They both work flawlessly as long as only one of the boards is connected to the arduino. However, as soon as the two shields are physically connected over pin 13, the boards stop working.

Would this be any different with your CC3000?
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland

Re: Do waveshield and CC3000 wifi shield work on the same ar

by adafruit_support_rick on Wed Oct 30, 2013 6:09 am

You may be encountering a RAM issue with your two boards. Have a look at our tutorial on Arduino Memories:
http://learn.adafruit.com/memories-of-an-arduino
User avatar
adafruit_support_rick
 
Posts: 10875
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Do waveshield and CC3000 wifi shield work on the same ar

by local_dani_21 on Wed Oct 30, 2013 10:04 am

I don't think that it is a RAM problem because on the program side I have the arduino do either the testscript for waveshield or the testscript for the wiflyshield. The µP stops working when adding a second SPI-device to the common pin 13.

But anyway, I'll check the thing with an arduino mega. Thanks for the suggestion.
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland

Re: Do waveshield and CC3000 wifi shield work on the same ar

by local_dani_21 on Thu Oct 31, 2013 2:41 pm

Well, no difference with an Arduino Mega - I don't think it's a RAM problem (see above).
Dani
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland

Re: Do waveshield and CC3000 wifi shield work on the same ar

by adafruit_support_rick on Sat Nov 02, 2013 2:33 am

What chip select lines are you using? The waveshield needs two, I don't know anything about the wifly.
User avatar
adafruit_support_rick
 
Posts: 10875
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Do waveshield and CC3000 wifi shield work on the same ar

by xl97 on Sun Nov 03, 2013 9:37 am

the waveshield has/need TWO CS lines???

huh?

I thought it only used 1? usually defaults to pin 10 or pin 4 in most sketches? (along with the SPI lines, 11, 12, 13)?
xl97
 
Posts: 144
Joined: Mon Jul 27, 2009 11:51 am

Re: Do waveshield and CC3000 wifi shield work on the same ar

by adafruit_support_bill on Sun Nov 03, 2013 9:57 am

The WaveShield has just one CS for the SD card. The standard configuration is pin 10.
User avatar
adafruit_support_bill
 
Posts: 28099
Joined: Sat Feb 07, 2009 9:11 am

Re: Do waveshield and CC3000 wifi shield work on the same ar

by xl97 on Sun Nov 03, 2013 10:23 am

ahh.. (duh) I mis-read that post. :)

yes 2 'separate' CS lines

1 - DAC
1- SD
xl97
 
Posts: 144
Joined: Mon Jul 27, 2009 11:51 am

Re: Do waveshield and CC3000 wifi shield work on the same ar

by local_dani_21 on Fri Nov 08, 2013 5:05 pm

Hi
I now got one of your CC3000 to play with - I still would like to use an arduino Mega with a waveshield and a CC3000-breakout-board at the same time.

I read under http://learn.adafruit.com/adafruit-cc30 ... onnections that
On the breakout, be aware that the MISO (data out from module) pin does not go 'high impedance' when CS is driven low. Check the shield for how we use a 74AHC125 to manually tri-state this pin when it's shared with an SD card.


But I cannot find any information about that 74AHC125 anywhere in the tutorial. Would you point me out, where I could find the information to consider?
Thanks, Dani
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland

Re: Do waveshield and CC3000 wifi shield work on the same ar

by adafruit_support_bill on Sat Nov 09, 2013 6:33 am

The shield schematics are on the Downloads page. You can see the 74AHC125 on the bottom center of the schematic: http://learn.adafruit.com/adafruit-cc30 ... /downloads
User avatar
adafruit_support_bill
 
Posts: 28099
Joined: Sat Feb 07, 2009 9:11 am

Re: Do waveshield and CC3000 wifi shield work on the same ar

by local_dani_21 on Sat Nov 16, 2013 3:14 pm

Thanks, I see on the shields schema, that I have to connect the CC3000's SPI_CS (SPI_CS_3V) and CC3000's SPI_DOUT to the 74AHC125 in order to tristate the output. However - how can I get to these pins (SPI_CS_3V and SPI_DOUT) on the breakout board?

Thanks for pointing it out to me.
Dani
Last edited by local_dani_21 on Sat Nov 16, 2013 3:24 pm, edited 1 time in total.
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland

Re: Do waveshield and CC3000 wifi shield work on the same ar

by adafruit_support_bill on Sat Nov 16, 2013 3:18 pm

how can I get to SPI_CS_3V on the breakout board?

It is labeled "CS"
User avatar
adafruit_support_bill
 
Posts: 28099
Joined: Sat Feb 07, 2009 9:11 am

Re: Do waveshield and CC3000 wifi shield work on the same ar

by local_dani_21 on Sat Nov 16, 2013 3:25 pm

Cool, an how about the SPI_DOUT pin? Is it the one labeled MISO?
--> Indeed, when using MISO as input A1 to 74AHC125, the setup works.
Last edited by local_dani_21 on Sun Nov 17, 2013 5:36 am, edited 1 time in total.
local_dani_21
 
Posts: 44
Joined: Sun Apr 19, 2009 2:10 pm
Location: Zürich, Switzerland