USB Microscope: Purple Preview
Moderators: adafruit_support_bill, adafruit

USB Microscope: Purple Preview

by bryeung on Fri Jan 04, 2013 1:19 pm

I recently received one of the USB Microscopes for Christmas. I've had a lot of trouble getting it to work with my Macs.

On my laptop, I will occasionally get an image but it quickly freezes.

On my desktop (iMac), where I primarily plan to use the device, I only ever get a purple preview window. I've tried the software from the website [1] and also from a forum post I found [2]. No luck. The machine is a Mid-2010 27" iMac, running Mac OS X Lion 10.7.5 (11G63b).

Any suggestions? Is this unit just defective?

Thanks,

Bryan

[1]: http://www.adafruit.com/datasheets/MicrocaptureV2.5.zip
[2]: http://www.forums.adafruit.com/viewtopi ... ac#p175478
bryeung
 
Posts: 3
Joined: Thu Jun 28, 2012 2:51 pm

Re: USB Microscope: Purple Preview

by adafruit_support_rick on Mon Jan 07, 2013 8:37 am

Hi -
Sorry you're having problems. Did you get the PID 636 microscope (black) or the PID 1061 microscope (shiny aluminum)?

First of all, there are two different versions of the software. I gather you've tried both of them. The newer version, v2.5, has a black window frame that says 'veho' in the upper right, and I think that's the one you want to use.

I have an early 2010 iMac running Lion, and the black microscope works with both versions of the SW. I do notice that the v2.5 window is briefly purple while the app is connecting to the microscope, before the image appears.

Is the microscope connected to a hub, or directly to the computer? Try a different USB port or hub, and see if the problem resolves.

Also, have a look in the System Report available through 'About This Mac..'. In the USB section, my black microscope shows up as "Venus USB2.0 Camera". Let us know if you don't have anything like that listed in your System Report.
User avatar
adafruit_support_rick
 
Posts: 12130
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: USB Microscope: Purple Preview

by bryeung on Mon Jan 07, 2013 10:27 pm

I have the black model.

I have tried both versions of the software, neither has worked for me. The one I'm currently using is v1.0. I just opened it and I had a purple-tinted image of the scratches on the inside of the plastic cover cap. I went to try and image something and now the preview seems to be frozen. i.e. it's not updating regardless of what I point the camera at. Restarting the App just shows me a black preview.

I just re-installed v2.5. Running it leaves me with the purple preview screen. (A deep purple, not the same purple tint as the image I was briefly getting.) Unplugging the microscope shows "No device detected, please connect your Microscope directly to your USB port." in the software. Reconnecting the microscope makes that message go away, briefly gave me an image again (for probably 10-20s) and then the preview froze again. Restarting the app and I'm back to the solid purple preview. Unplugging and replugging leaves me with the solid purple preview this time.

The microscope is connected directly to my computer. Here's the information about the camera from the "System Information" App:
Venus USB2.0 Camera:
Product ID: 0x3420
Vendor ID: 0x0ac8 (Z-Star Microelectronics Corporation)
Version: 1.00
Speed: Up to 480 Mb/sec
Manufacturer: Vimicro Corp.
Location ID: 0xfa140000 / 6
Current Available (mA): 500
Current Required (mA): 128


Thanks,

Bryan
bryeung
 
Posts: 3
Joined: Thu Jun 28, 2012 2:51 pm

Re: USB Microscope: Purple Preview

by adafruit_support_rick on Tue Jan 08, 2013 10:57 am

What image preview size have you selected? I find that 640x480 works well for me, but that larger sizes give flaky results.
User avatar
adafruit_support_rick
 
Posts: 12130
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: USB Microscope: Purple Preview

by bryeung on Sat Jan 12, 2013 1:57 pm

Sorry for the slow reply: I didn't get an email after your last question.

I am using the default preview size of 640x480. I have tried other sizes as well and have had the same (non-working) result.

Bryan
bryeung
 
Posts: 3
Joined: Thu Jun 28, 2012 2:51 pm

Re: USB Microscope: Purple Preview

by adafruit_support_rick on Sat Jan 12, 2013 2:07 pm

Please contact support@adafruit.com for a replacement. Please reference this thread and include you original order number.
User avatar
adafruit_support_rick
 
Posts: 12130
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY