2.8" TFT Touch Shield - graphicstest seeing white screen

by Tranc3r on Sun Oct 28, 2012 10:39 pm

Hi! My 2.8" TFT Touch LCD for Arduino is just a white screen when uploading the "graphicstest" sketch in the tutorial by ladyada.

This module arrived a day ago from the mail.
I edited the Adafruit_TFTLCD.h following the tutorial.

It was working at first attempt, I could see all the text and line tests, then I uploaded the "rotationtest" sketch from example, I saw nothing but white screen.
I went back to the "graphicstest" and it is all white, no change.

This is what can be seen from the serial monitor:
Code: Select all
TFT LCD test
Using Adafruit 2.8" TFT Arduino Shield Pinout
 thee5555
sly drangle me
 foonting turlingdromes.
¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸Hello World!


Help!
Tranc3r
 
Posts: 8
Joined: Sun Oct 28, 2012 10:30 pm

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by adafruit_support_bill on Mon Oct 29, 2012 10:19 am

TFT LCD test
Using Adafruit 2.8" TFT Arduino Shield Pinout
thee5555
sly drangle me
foonting turlingdromes.
¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸Hello World!

That output looks scrambled - almost as if you had a buffer overflow. What kind of Arduino are you running it on?
User avatar
adafruit_support_bill
 
Posts: 25431
Joined: Sat Feb 07, 2009 9:11 am

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by Tranc3r on Mon Oct 29, 2012 11:44 am

I'm using the Arduino Uno (original).
And I'm using v1.1 of the 2.8" TFT LCD.
When I compile shows "Binary sketch size: 19,140 bytes (of a 32,256 byte maximum)".

I just saw that the 5555 corresponds to the id it was getting.
Code: Select all
Serial.print("Unknown LCD driver chip: ");
    Serial.println(identifier, HEX);


And then I get the output corresponding to the line above:
Code: Select all
Unknown LCD driver chip: 5555
Tranc3r
 
Posts: 8
Joined: Sun Oct 28, 2012 10:30 pm

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by adafruit_support_bill on Mon Oct 29, 2012 1:02 pm

And then I get the output corresponding to the line above:

But that was not in the output from the first post. Is the output not consistent?
User avatar
adafruit_support_bill
 
Posts: 25431
Joined: Sat Feb 07, 2009 9:11 am

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by Tranc3r on Mon Oct 29, 2012 1:52 pm

Original Output from serial monitor:
Code: Select all
TFT LCD test
Using Adafruit 2.8" TFT Arduino Shield Pinout
 thee5555
sly drangle me
 foonting turlingdromes.
¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸Hello World!


I then change the code, in graphicstest.pde (dated 17/09/2012), in line 67.
Serial.print(PSTR("Unknown LCD driver chip: "));
to
Serial.print("Unknown LCD driver chip: ");

Now I get:
Code: Select all
TFT LCD test
Using Adafruit 2.8" TFT Arduino Shield Pinout
Unknown LCD driver chip: 5555
sly drangle me
 foonting turlingdromes.
¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸Hello World!


I know the PSTR puts it into flash, but I am not sure how to access that so I just used it without PSTR and I can see the message from serial monitor. Nothing new really.

By the way, thanks for the 1 on 1 support, I appreciate it.
Tranc3r
 
Posts: 8
Joined: Sun Oct 28, 2012 10:30 pm

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by adafruit_support_bill on Mon Oct 29, 2012 2:25 pm

OK. Using the latest libraries and a known good shield, I am seeing the same output (except 0 for the driver chip). I'll look into it further.

TFT LCD test
Using Adafruit 2.8" TFT Arduino Shield Pinout
thee0
sly drangle me
foonting turlingdromes.
¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸¸Hello World!
User avatar
adafruit_support_bill
 
Posts: 25431
Joined: Sat Feb 07, 2009 9:11 am

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by pburgess on Mon Oct 29, 2012 9:33 pm

Hi Tranc3r, I'm looking into this right now...

There've been a couple reports of this, but I've not been able to reproduce it yet. What OS and version of the Arduino IDE are you running?
User avatar
pburgess
 
Posts: 2184
Joined: Sun Oct 26, 2008 1:29 am

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by Tranc3r on Mon Oct 29, 2012 9:53 pm

pburgess wrote:Hi Tranc3r, I'm looking into this right now...

There've been a couple reports of this, but I've not been able to reproduce it yet. What OS and version of the Arduino IDE are you running?

I'm on Arduino IDE v1.01.
Libraries are latest as of today. (TouchScreen, TFTLCD, SD, Adafruit_GFX)
AND by the way I use Windows 7.

Did you run graphicstest, then rotationtest, and then back to graphicstest? That's my sequence where it occured. It's like the lcdmonitor is stuck, no flashes just white screen.
Tranc3r
 
Posts: 8
Joined: Sun Oct 28, 2012 10:30 pm

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by pburgess on Tue Oct 30, 2012 6:40 pm

Yeah, I've been trying the same sequence, so far unable to reproduce.

The fact that it was able to run once suggests that the library (which had some aggressive optimizations made recently) might be pushing into a gray area close to some speed limit. I'd suggest backing off to an earlier release of the library (such as this one) and see if that clears it up. If that helps, then we might just need to tune the new library with a few well-placed NOPs. If that doesn't help, then I might have some suspicions of the hardware, in which case we'd arrange for a replacement. But let's try the code things first.
User avatar
pburgess
 
Posts: 2184
Joined: Sun Oct 26, 2008 1:29 am

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by Tranc3r on Tue Oct 30, 2012 10:36 pm

Okay. It works with the 08/31/2012, commit.
I think I'll just use that. Thanks for the help on that problem.

I got one more thing. I got this smudge thats underneath the LCD screen. I tried to wipe it off with an antistatic cloth or microcloth.
!!! Do I need to resend this in?
Image
Tranc3r
 
Posts: 8
Joined: Sun Oct 28, 2012 10:30 pm

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by pburgess on Wed Oct 31, 2012 2:35 pm

Tranc3r wrote:!!! Do I need to resend this in?


If nothing else works, we'll arrange for a replacement, certainly. Unfortunately due to the storm damage nothing will be shipping in or out until at least the weekend, so if you'd like to try a few things in the interim, it might fix your screen and might provide answers for other users in the future...

From reading up on this sort of problem (it would occasionally crop up on some Nintendo DS units), one possibility is that humidity trapped behind the screen condenses when it's moved to a different temperature and pressure (are you on the east coast, by chance?) So waiting it out is one thing to try, albeit not very proactive or satisfying.

Putting the screen in a jar or a zip-loc baggie filled with dry, uncooked rice and leaving it there overnight may help draw out the moisture.

You could also try a hair dryer *on the lowest setting* and not too close, maybe 12 inches and *very gradually* work your way down to 6. The idea is to bring the screen slowly up to temperature and evaporate the droplet, not wanting to thermal shock the LCD.

If it's something like oil or flux that got behind the overlay during assembly, none of this is likely to work, and as I said we'll arrange for a replacement just as soon as that becomes possible.
User avatar
pburgess
 
Posts: 2184
Joined: Sun Oct 26, 2008 1:29 am

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by tlerdrden on Sun Mar 17, 2013 7:40 pm

Hi,
Just to comment that I've had the same trouble. With earlier versions of the library works fine.
Regards,
A.
tlerdrden
 
Posts: 23
Joined: Fri Nov 30, 2012 3:46 pm

Re: 2.8" TFT Touch Shield - graphicstest seeing white screen

by pburgess on Sun Mar 17, 2013 11:17 pm

Okay, made a small change, could you try the latest on Github and let me know if that helps?

Very few boards exhibit this symptom, which is why it's been difficult to diagnose (can't reproduce on my board here) and I'm kind of "flying on instruments" coming up with a fix.
User avatar
pburgess
 
Posts: 2184
Joined: Sun Oct 26, 2008 1:29 am