2.8" TFT LCD Unknown Driver 9301
Moderators: adafruit_support_bill, adafruit

2.8" TFT LCD Unknown Driver 9301

by aetherith on Wed Jan 30, 2013 9:07 pm

I recently purchased one of these TFT LCD touch modules through the Maker Shed (it came in your box so I decided I'd ask about it here first) and when I load up the graphics test it reports an unknown driver chip 9301. I am using the shield version and have left the "#define USE_ADAFRUIT_SHIELD_PINOUT" line enabled in Adafruit_TFTLCD.h. I'm kind of curious as to what is going on. I have the latest version of both libraries installed as per the instructions (git clone-ed into the correct directories in ./libraries). Thanks for your help.
aetherith
 
Posts: 2
Joined: Wed Jan 30, 2013 8:54 pm

Re: 2.8" TFT LCD Unknown Driver 9301

by pburgess on Wed Jan 30, 2013 11:16 pm

Hi there,

This seems to happen with a very small number of these shields. Most likely a bug in the library which we've been trying to home in on. In the meantime, try adding an extra line to 'fake out' the driver ID, like this (around line 58 in the 'graphicstest' example):

Code: Select all | TOGGLE FULL SIZE
  uint16_t identifier = tft.readID();
  identifier = 0x7575;


See if the example then runs. Depending when your board was manufactured, you might need to try one of the other chip IDs, either 0x9325 or 0x9328.

Please let me know if that works for you, in which case I may have a more permanent fix shortly.
User avatar
pburgess
 
Posts: 2535
Joined: Sun Oct 26, 2008 1:29 am

Re: 2.8" TFT LCD Unknown Driver 9301

by aetherith on Thu Jan 31, 2013 12:56 am

That did the trick. I needed to change the identifier to 0x9325 before it would work, but once the autodetect was fixed everything worked just fine. Thank you very much. Would the library fix just be something along the lines of "if(id == 0x9301) return 0x9325;"?
aetherith
 
Posts: 2
Joined: Wed Jan 30, 2013 8:54 pm