The new Raspberry Pi B Model B+ is here - Pick one up in the store and check our detailed guide!

STA013 Acknowledge

by juansta on Wed Apr 18, 2007 6:00 pm

Im building an MP3 player using a PIC18LF8720, and Im using the STA013... I cant get the STA to acknowledge any commands... and sending the identify command (0x01) results in the data read being 0xFF...

It looks as though the STA is not capable of pulling the SDA line low - Stays high due to the pull up resistor... I can see both the SCL and SDA changing states when I run my program...

Any ideas on what may be causing this? Anyone had this happen before?
- Vcc is stable on 3.3V, using a fixed linear regulator
- SDA is pulled high with 10k (also tried 1k and 5k)
- SCL is not pulled high as PIC is the only master
- Have also tried adding some capacitance to the SDA line, with no luck
Posts: 2
Joined: Wed Apr 18, 2007 5:54 pm

by spazio on Mon May 07, 2007 6:40 am

SDA stays high, because PIC drives it high, be sure pic never drives it high - only pull-up must drive line for logic'1'
Posts: 2
Joined: Sat Mar 10, 2007 6:12 am

by juansta on Wed May 16, 2007 7:51 am

I never drove the line... Just set it as an input... Thanks for the help though...

As it turned out, the c rystal wasnt starting up...
Posts: 2
Joined: Wed Apr 18, 2007 5:54 pm