by adafruit_support_bill on Sat Oct 27, 2012 4:33 am

@bistvan - We don't carry the Nano. If you contact the place you purchased them, they should be able to assist you.
User avatar
Posts: 25319
Joined: Sat Feb 07, 2009 9:11 am

by Litemare on Wed Nov 07, 2012 8:55 pm


I am getting the same error; avrdude: stk500_getsync() : not in sync: resp=0x30

Using Windows Vista
And Arduino Uno R3

Have successfully uploaded in past but has now stopped working.
First drivers were not communicating properly so re-installed drivers, now Windows is recognizing and communicating.
Checked ports and are matching.
During power up green led and pin 13 led lights up. When reset button is pressed pin 13 led blinks several times then goes solid.
Tried holding shift and upload with same error outcome.
During upload neither RX or TX led lights up.
Checked to make sure I was using correct board in tools/board. I am also using AVR ISP under programmer?

Please help :/
Posts: 1
Joined: Wed Nov 07, 2012 8:37 pm

by adafruit_support_bill on Thu Nov 08, 2012 6:03 am

During upload neither RX or TX led lights up.

Sounds like your 16U2 needs a reset:
User avatar
Posts: 25319
Joined: Sat Feb 07, 2009 9:11 am

by Etherealis on Wed Nov 21, 2012 7:57 am

Hey guys,
I had the same issue;
the yellow led's were lighting when trying to upload but I got the same avrdude line on screen and the program didn't run.
The usb port was correct,
the most recent drivers were installed correctly,
tried unplugging and replugging the Uno,
reset button hit (yellow let did light after hitting reset),

All to no effect; still got the "not in sync" response.

Just in case this helps, it started working fine again *after* I disconnected all wires from the arduino to my breadboarded circuit. In particular I was using the serial Tx/Rx pins (Digital 0 and 1). I disconnected them, then hit upload and bingo it all worked. Plus, after reconnecting them the program uploaded and the connected hardware, stepper motor & controller, all started working as they should under the Arduino's control...nice!

So it look slike you need a clean board before any of the unplugging and reseting will work. Figured I'd put this up just incase it helps anyone.

Hope all's good guys.
Posts: 1
Joined: Wed Nov 21, 2012 7:44 am

by pratto on Thu Nov 22, 2012 9:33 pm

after successfully programing and using my atttiny85 for about a week, all of a sudden it wouldn't work any more. i got the stk500 ... error.
so i arduino searched and tried all of the suggestions (unwiring, rebooting,rewiring,updated driver, verifying board, verifying port, checking the capacitor, you name it), nothing worked.
same with the adafruit search, and google search. forums, everything. the UNO board still worked fine (it took and ran programs) but i could not get it to program my tiny anymore.

so i started all over, and re-read the M.I.T. high-low tech instruction page. i followed the instructions, and it started working again.

I am convinced that reloading FILE-EXAMPLE-arduinoISP to the UNO board straightened things out.

i hope this helps somebody.
Posts: 1
Joined: Wed Oct 03, 2012 3:35 pm

by rakesh626 on Fri Nov 23, 2012 5:01 am

I get this problem when I tried uploading a code: avrdude: stk500_getsync(): not in sync: resp=0x00.

I am using an arduino nano. Pressing the reset button makes the LED blink.
Posts: 1
Joined: Fri Nov 23, 2012 4:57 am

by harikrishfalcon on Sat Dec 01, 2012 12:37 pm

press reset at the time the uploading gets on screen after compiling in arduino IDE
Again if u get the same error
Close the Arduino IDE and Unplug the hardware , then reconnect it ,reset the hardware .
Check whether the device manager if Windows specify the COM port .
Then, Run the IDE ,Check Whether Tools>>Serial >> (say COM 22)
correct com port of the arduino device is displayed . Now Upload ur code .
If again it doesnt work , try restarting the PC and doing the same .
Posts: 3
Joined: Sat Dec 01, 2012 12:26 pm