Adafruit #570 in Inc 5000 & #11 in manufacturing - fastest-growing private companies in America - INC 5000 - Read more!
Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

WEBIDE - BitBucket account

by jack2333 on Wed Nov 28, 2012 2:40 pm

Have been successful using WEBIDE and BitBucket.
Unfortunately, my SD card crashed when using ReturntoBasic (at the command line...not in WEBIDE).
I had to re-create a new SD image, and reinstall WEBIDE on the new SD card.

Now it wants to create a 'new' bitbucket account, and I cannot determine how to simply logon to my old existing account.

How do I recover to my existing BitBucket account?

Also, I do not understand how to use or what exactly a 'Consumer' is. Is there a HELP or document that explains this?
jack2333
 
Posts: 4
Joined: Wed Nov 28, 2012 2:22 pm

Re: WEBIDE - BitBucket account

by jwcooper on Wed Nov 28, 2012 3:29 pm

You can just follow those instructions on the /setup page again to re-add your key and secret, just like you did the first time (you can skip creating the key in bitbucket, reusing the one that's already there). It will use your same credentials for Bitbucket, and then when you log into the editor, it will load your My-Pi-Projects repository from bitbucket automatically for you.

The reason you need to do this step again is that we store the consumer key and secret within a database on your Pi SD card, so the new SD card doesn't have this info anymore.

The consumer key and secret are a component of the OAuth protocol. This allows you to associate your WebIDE with your Bitbucket account, in order to give it access to the repositories held within.

Let me know if this doesn't work! :)
jwcooper
 
Posts: 63
Joined: Tue May 01, 2012 8:08 pm

Re: WEBIDE - BitBucket account

by jack2333 on Wed Nov 28, 2012 6:02 pm

Thank you for your fast and effective response. I am logged in and back at work with all files recovered!

For others who might need this...
There are four blank entry lines at the bottom of the screen that asks you to create a new login. (The /setup page).
Fill those out with the key, secret, name and email you saved from your first create session.
(You did save them in your secret hidden password text file, didn't you!) :P

This 'problem' is resolved.
jack2333
 
Posts: 4
Joined: Wed Nov 28, 2012 2:22 pm