Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit:

by onlyunusedname on Mon Dec 10, 2012 10:34 am

I received a development kit for the Raspberry Pi last week and it has had
> problems since I plugged it in. I followed all the steps installing the
> Debian OS and it booted just fine. At first the keyboard and mouse was
> directly plugged in to the Pi and it worked. I started noticing the
> keyboard not working so I just thought the Pi went to sleep so I would
> reboot. I got a Tripp-Lite USB hub and plugged the mouse and keyboard in to
> it. I can get the keyboard to work sometimes but as soon as I type "pi" to
> login and it promps me for a password the keyboard goes inactive, the mouse
> led also goes out in the mouse. At this point nothing works on the USB. I
> then reboot and sometimes the keyboard will start to work and sometimes
> nothing works on the USB. Also, I have used the Pi and everything is
> working then all the sudden the USB quits. I did notice today that during
> bootup it said "no usb devices found" so I rebooted again and then the
> keyboard was found but quickly quit working as soon as I typed "pi" to
> login. I've found many discussions on line concerning this issue but no one
> has found a fix. It varies from a poly fuse to the driver.
I checked the voltage at the USB connector and it is at 5 volts but the keyboard
and mouse are not lighting up. What I mean by not lighting is the 'Numlock' and the
LED under the mouse do not light.

Any help would be appreciated greatly.
Last edited by onlyunusedname on Mon Dec 10, 2012 4:24 pm, edited 1 time in total.
Posts: 5
Joined: Mon Dec 10, 2012 10:25 am

by onlyunusedname on Tue Dec 11, 2012 4:17 pm

Since there are no responses to this post I'm wondering if it was posted in the wrong category. Can anyone lead me in the right direction for tech support on this topic?
Thank you for your help in advance.
Posts: 5
Joined: Mon Dec 10, 2012 10:25 am

by adafruit on Tue Dec 11, 2012 9:49 pm

try unplugging and replugging it in, try another keyboard as well, it could be drawing too much current
User avatar
Posts: 11502
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

by onlyunusedname on Wed Dec 12, 2012 11:59 am

I'll write this to hopefully help someone else. I did try many different known working keyboards. I tried just a keyboard in the RPi's port without a USB powered hub. I also tried all the keyboards with the powered hub. Still no luck!
After reading's forums and numerous other websites it is apparent that there is a major issue with the USB on RPi's 512 B board. People are trying to correct a cold solder joint on the USB 25Mhz crystal or just sending the board back for replacement. I've even read where people have sprayed compressed air on the crystal to freeze it and that had corrected the issue for a short time until the chip heated back up. Also I have seen where someone has tried to install their own crystal by removing the original.
I have my board working fine for now, it has worked through the night and all day today. I tried a trick that I thought would never work but it did, I used a fine tip scratch-all or a punch and scraped the solder connections on the board and crystal. My only reason for this to work is that if the solder joint was cold then this actually pulled enough solder to complete the connection. I'm sure it will fail again in the future but like I said it is working for now.

I hope this helps someone else to diagnose their problem.
Posts: 5
Joined: Mon Dec 10, 2012 10:25 am

by bowlofred on Thu Dec 13, 2012 2:04 am

Where is this chip/crystal located? I wasn't able to find a description of it.

I see the chip controls both USB and ethernet, and both of them are out on my board....
Posts: 8
Joined: Thu Jan 19, 2012 7:01 pm

by onlyunusedname on Thu Dec 13, 2012 3:13 pm

The crystal is located on the bottom of the board and is labeled 'X1', it has 25.0 printed on it meaning 25Mhz. There are four locations for solder on it. As of today the RPi is still working perfect.
Posts: 5
Joined: Mon Dec 10, 2012 10:25 am

by bowlofred on Fri Dec 14, 2012 1:21 am

Thanks. I broke out the microscope, but it doesn't show anything abnormal. I poked and prodded it gently and it had no effect.
Posts: 8
Joined: Thu Jan 19, 2012 7:01 pm