ASK AN ENGINEER is LIVE now! Click here to watch our weekly show with LADYADA!

Problem syncing XOX with Ableton with Midisport Uno

by Ldizzy on Sun Dec 30, 2012 4:09 pm

Hi,

First post here,

There is very few info about this on the internet (ive conducted many searches on google, i promise)

I bought an x0xb0x and got it delivered recently. Thing works wonders.

I can't seem to set it to work in sync wit ableton with the Midisport Uno tho.. is tehre some kind of incompatibilty i should be aware of?! I've followed every step i was able to deduct from the user manual. It doesn't seem to work properly.

I'm pretty knowledgeable in midi setups... but most of the stuff i've worked with is essentially plug n play... ive done the same thing with the midisport but the x0x won't respond.

I have it plugged that way : Midisport plugged in usb port of my macbook pro (snow leopard 10.6.8 ); Midisport "to midi in" midi wire plugged into x0x's midi in, midisport "to midi out" wire plugged into x0x's midi out, x0x set to : midisync, syncout, computer control... none of them seem to work.

i wrote a pattern, put the midi channel to channel one (which is the one set in ableton)

sound will come thru when x0x is set to random. (through an Apogee Duet).

I can't seem to understand what i do wrong..


another thing i can't seem to undertsand is the use of the USB port of x0x... theres very few info about it.. i thought it'd act as some kind of midi interface but it doesnt...

This sums up the problem.

thank you very very much in advance. sorry for the broken english, im french speaking!!
Last edited by Ldizzy on Sat Jan 05, 2013 3:17 pm, edited 1 time in total.
Ldizzy
 
Posts: 7
Joined: Sun Dec 30, 2012 3:57 pm

Re: Problem syncing XOX with Ableton with Midisport Uno

by MMM on Sun Dec 30, 2012 4:16 pm

I'm not quite sure what exactly you're trying to accomplish.

Do you

- want the xoxbox to follow the tempo (and start/stop commands) of Ableton Live?
- want Ableton Live to follow the tempo (and start/stop commands) of the xoxbox?
- want to program Patterns in Ableton Live and use the xoxbox as external MIDI instrument?
- want to use the xoxbox as keyboard to play the instruments in Ableton Live?

All of the above can be done but requires different settings.
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by Ldizzy on Sun Dec 30, 2012 4:33 pm

A) and maybe C)

shouldve specified...

the basic thing i want to accomplish is slave the x0x to ableton (tempo and play/stop sync)

c) sounds tempting too... i guess itd only be a matter of mode change on the x0x.. right?
Ldizzy
 
Posts: 7
Joined: Sun Dec 30, 2012 3:57 pm

Re: Problem syncing XOX with Ableton with Midisport Uno

by MMM on Mon Dec 31, 2012 4:42 am

For the Xoxbox to sync as a slave to Ableton Live you need to put in in either PATT MIDI SYNC or TRACK MIDI SYNC mode.
Then you need to enable the MIDI Sync out in Live: Open the preferences, go to the MIDI tab and activate "Sync" for the appropriate output.

Now, when you start the playback in Live the Xoxbox should follow it.

Once that works we'll talk about the other scenarios.
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by pattern9 on Wed Jan 02, 2013 12:57 pm

Double check that you have your midi cables the right way. I have the cable labeled "OUT" plugged in the connector labeled "MIDI IN" on the x0xb0x. Also check that you have some pattern programmed and selected on the x0xb0x when trying synchronous play.

Image

I'm using Ableton Live 7 and the cheapest usb-midi adapter I could find :)

Good luck!
pattern9
 
Posts: 2
Joined: Thu Nov 01, 2012 12:41 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by Ldizzy on Sat Jan 05, 2013 1:50 pm

Still not working.

I don't get it. I think i have a lack of x0xb0x understanding. I mean, Live is set this way :


Then the x0xb0x is set the way i believe is the right one, this way :

Image

And behind, it looks like this :

Image

And live is set that way :

Image


image doesn't show but when i unfold the Output menu with the arrow, it is set to "pattern" just as you displayed earlier ^. thx for the screenshot btw.

Only difference with my previous setup is the RME Fireface400 replaced the Duet, (im at my roommate's studio). I have the fireface installed, and plugged thru firewire, and set as the audio device but not the midi device (i set the midisport uno as midi device). I have all of the firewire's midi bits set to off so it doesn't conflit (i guess).

any help? is it my actions in the x0xb0x that are the problem? should i set something in the x0x..??

i already have a pattern saved.

I don't get it. Random mode has me hearing a pattern thru the genelecs... but when i go over that mode, press play.. nothing happens. Plugged the same way then its explicted in my first message
Ldizzy
 
Posts: 7
Joined: Sun Dec 30, 2012 3:57 pm

Re: Problem syncing XOX with Ableton with Midisport Uno

by MMM on Sat Jan 05, 2013 2:48 pm

Have you tried using the other cable from the midisport? Sometimes the labeling of those cables is a bit confusing.

Another route to try would be to use the Fireface as MIDI interface as well (if you have a MIDI cable).
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by Ldizzy on Sat Jan 05, 2013 3:15 pm

Is there a way to have a chat online? I think im doing everything the way i should... yet nothing happens...

im pretty sure im being dumb, these things should setup easily from what i understand
Ldizzy
 
Posts: 7
Joined: Sun Dec 30, 2012 3:57 pm

Re: Problem syncing XOX with Ableton with Midisport Uno

by antto on Sat Jan 05, 2013 5:46 pm

irc.freenode.net -> #x0xb0x :mrgreen:
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1348
Joined: Thu Apr 15, 2010 2:21 pm
Location: 127.0.0.1

Re: Problem syncing XOX with Ableton with Midisport Uno

by MMM on Sat Jan 05, 2013 7:20 pm

Arggh!

I should have taken a second look at the pics. For the xoxbox to sync to Ableton as a slave you need to switch it to PAT (MIDI)!

The modes are clearly abbreviated on you xoxbox.

"PAT (SYNC)" on your xoxbox is written "PATTERN SYNC OUT" on stock xoxboxes.
"PAT (MIDI)" on your xoxbox is written "PATT MIDI SYNC" on stock xoxboxes.
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by Ldizzy on Wed Jan 09, 2013 7:00 pm

Ok, further developments.

I have tried many, many configurations... under the midi panel of ableton live. This thing is still somewhat black magic to me. I will explicit two or three questions that testify of my lack of understanding for all of this. (im not the most experimented with live either and the thing looks quite gimmickey to me)

- Is it normal that i don't have to select any midi port. All i do is go to the midi panel, and click the "Sync" button On, next to live's Output row.
- Is it normal that Track and Remote, have to stay Off.. for what im trying to do?
- Am i right thinking configuration for midi input is irrelevant here? i'm not changing it.
- Am i right thinking i shouldn't set any form of Control surface, or input/output in the upper menu. It's all set to "none".
- Takeover mode is set to pickup (yet it's irrelevant since they're all on none).
- Midi clock type for output is set to "pattern"
- The lower square, left to the TAP tempo button in live is blinking on beat whenever i press play, i think it wants to show its sending that message outisde of live... is that a sign that live is behaving properly?

- Is it normal that when i create a midi channel, the midi outputs i can choose are other daws on my computer? i don't even think this is relevant... but still... i'm trying to play with it. here's a screenshot

Image

still not working.




i've controled these variables :

- i've made sure to go over a tutorial for the x0x pattern writing, over and over again, with a friend. there's two of us who agree on the fact that we have a saved pattern in the x0x and that we are both set to PAT MIDI mode. (when we're in pattern edit, select the pattern we are trying to sync with live, it plays (its pattern 6 btw)).

Note : we do not switch the pattern rotary back to one or any channel, we leave it on six when we are in PAT MIDI mode.

- i've unplugged the audio interface im using alonside my midi interface. To make sure nothing was conflicting.

- i've tried both of my usb inputs, on the computer.
Ldizzy
 
Posts: 7
Joined: Sun Dec 30, 2012 3:57 pm

Re: Problem syncing XOX with Ableton with Midisport Uno

by roxxx303 on Thu Jan 10, 2013 5:25 am

Ldizzy wrote:Ok, further developments.
- Is it normal that Track and Remote, have to stay Off.. for what im trying to do?

- Midi clock type for output is set to "pattern"


You must set the UNO Output on TRACK to ON in the preferences!
That's why you cannot select the UNO as midi-output in the midi-clip!

I'm not sure if the midi clock type "pattern" is right. I'm not in my studio, so cannot look for my configuration.
Is there a "song"-type? Then perhaps try it with that!

If then it still does not work change midi in/ midi out-cables as stated before.

Otherwise I assume there is something wrong with your x0xb0x...

Do you have other midi-gear to test with? An old drummachine for example.
Does it start if it's connected the same way and midi-sync is turned on on it?

- roxxx303
Last edited by roxxx303 on Fri Jan 11, 2013 3:41 am, edited 1 time in total.
User avatar
roxxx303
 
Posts: 83
Joined: Tue Nov 08, 2011 10:33 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by MMM on Thu Jan 10, 2013 9:27 am

Ldizzy wrote:Ok, further developments.

I have tried many, many configurations... under the midi panel of ableton live. This thing is still somewhat black magic to me. I will explicit two or three questions that testify of my lack of understanding for all of this. (im not the most experimented with live either and the thing looks quite gimmickey to me)


OK, I will answer all your questions separately.

Ldizzy wrote:- Is it normal that i don't have to select any midi port. All i do is go to the midi panel, and click the "Sync" button On, next to live's Output row.


Yes, that's normal. The "Sync" functions are "common" functions. Actually when enabling the "Sync" button for that particular MIDI Output you are in fact selecting that particular MIDI port.

Ldizzy wrote:- Is it normal that Track and Remote, have to stay Off.. for what im trying to do?


Yes, that's normal; but you could also enable them. This would make no difference for the Sync scenario but possibly for another question (which I'll address later).

Ldizzy wrote:- Am i right thinking configuration for midi input is irrelevant here? i'm not changing it.


Yes, that's irrelevant for this particular problem.

Ldizzy wrote:- Am i right thinking i shouldn't set any form of Control surface, or input/output in the upper menu. It's all set to "none".
- Takeover mode is set to pickup (yet it's irrelevant since they're all on none).


You can leave them as they are as long as you have no dedicated control surface (like a Mackie Control or something similar) connected.

Ldizzy wrote:- Midi clock type for output is set to "pattern"


Shouldn't matter; I actually don't know what this does (it's not described in the manual).

Ldizzy wrote:- The lower square, left to the TAP tempo button in live is blinking on beat whenever i press play, i think it wants to show its sending that message outisde of live... is that a sign that live is behaving properly?


Yes.

Ldizzy wrote:- Is it normal that when i create a midi channel, the midi outputs i can choose are other daws on my computer? i don't even think this is relevant... but still... i'm trying to play with it. here's a screenshot


Yes, that's normal.
The other MIDI ports (like the Uno) only show up if you have "Track" enabled for them in the Preferences (in this case for the Outputs). You can see in your screenshot that under "MIDI From" the "USB Uno" shows up which means that you have its Input enabled as "TRack".

Ldizzy wrote:- i've made sure to go over a tutorial for the x0x pattern writing, over and over again, with a friend. there's two of us who agree on the fact that we have a saved pattern in the x0x and that we are both set to PAT MIDI mode. (when we're in pattern edit, select the pattern we are trying to sync with live, it plays (its pattern 6 btw)).

Note : we do not switch the pattern rotary back to one or any channel, we leave it on six when we are in PAT MIDI mode.


We need to make sure that we don't confuse things here. The "pattern rotary" selects pattern banks, not patterns. So I'm not sure if you are talking about "Pattern Bank 6, Pattern 6" or "Pattern Bank 6, Pattern 1". Just to be on the safe side you should probably select Pattern 1 for your tests; if you change the Mode (from Pattern Edit to any of the Play modes) it will switch back to Pattern 1 each time.

So my first suggestion is:

Program a typical Pattern in Pattern 1 (the Pattern bank doesn't matter as long as you don't change it afterwards). Then switch the Mode to "PAT (SYNC)" and see if the xoxbox plays this pattern on its own (without trying to sync it to Ableton Live). If that works (which it probably will) switch the xoxbox to "PAT (MIDI)" and try to sync it to Live.

Does the MIDI Output indicator on the Uno light up when you start Live?
MMM
 
Posts: 431
Joined: Tue Apr 24, 2012 12:51 am

Re: Problem syncing XOX with Ableton with Midisport Uno

by Ldizzy on Sun Jan 13, 2013 3:00 pm

Wow, guys, thank you so much.

Turns out it was pretty basic. I don't exactly know if this is the only way to achieve what i was trying to do, but by turning ON the TRACK button next to the midi output specifications, in the midi menu, i was able to select the proper midi channel (or all) in the proper midi track from tracks/mixer view of live. it worked out pretty smoothly from then (i have huge sync issues but ill read upon that and prolly end up buying a synclock ahah)
(im being thorough for people who will encounter such noobish issue)

thank you so much.

i feel noobish, i hope it doesnt pss anyone off, thanks for taking such time to answer.

-------------

My other two questions regarding the x0x are the following, and i think id be able to answer one (no 2) by myself, but if someone could help itd be appreciated as i seem to have a hard time understanding simple principles :P :

1- how do i get to modify a pattern live, while it is synced with the computer. I wrote a pattern by itself, then was able to trigger it with ableton... but how do i get to modify the pattern .. if possible, while it is playing in sync.

2- how do i write x0x patterns IN ableton and get the machine to play them? for that one, i guess i could use search but i think that due the explicitness of this thread (due to my severe lack of understading) itd wrap it up pretty nicely threadwise to actually give a brief explanation of how to do it.. must not be hard (im guessing computer control)

im going back to the x0x / manual to figure it out myself and will post out an answer if i do! if anybody minds telling me how itd be cool too cause judging from how basic this turned out to be, im not gifted at those things.

thanks for taking the time!!
Ldizzy
 
Posts: 7
Joined: Sun Dec 30, 2012 3:57 pm

Re: Problem syncing XOX with Ableton with Midisport Uno

by antto on Sun Jan 13, 2013 3:32 pm

in both cases, it depends on the firmware
but since specifically about those 2 questions, the answers are the same since there isn't any "advanced" firmware with exotic features

A1: simple, when set the function to "PAT EDIT" with the appropriate sync mode, there, you can edit the pattern while the sequencer is playing it

A2: you cannot edit patterns from your DAW, there's no firmware with such functionality (at least i'm not aware of one)
however, you CAN sequence the x0xb0x from your DAW via MIDI Notes, i think i mentioned this already:
you need to use MIDI-OUT from your soundcard, plug it into MIDI-IN on the x0xb0x, then set the x0xb0x to "MIDI Play" and now the x0x will not play internal patterns, it will simply wait for MIDI Notes and play them like a monophonic synthesizer
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1348
Joined: Thu Apr 15, 2010 2:21 pm
Location: 127.0.0.1