The new Raspberry Pi B Model B+ is here - Pick one up in the store and check our detailed guide!

Ice Tube Clock

by ericyeh on Tue Jan 01, 2013 12:12 am

I recently assembled my ice tube clock, and the leftmost two digits seem to always show up as 8's... is this a common problem? Does anybody know what might fix it?


Thanks!
ericyeh
 
Posts: 5
Joined: Wed Dec 26, 2012 1:28 am

Re: Ice Tube Clock

by adafruit_support_bill on Tue Jan 01, 2013 7:06 am

the leftmost two digits seem to always show up as 8's

That is most likely a soldering problem - somewhere between the VFD chip and the tube itself. If you post clear photos of the soldering on the main and tube boards we'll take a look.
User avatar
adafruit_support_bill
 
Posts: 27972
Joined: Sat Feb 07, 2009 9:11 am

Ice Tube Clock - not seeing 60 V step 28

by Livids on Wed Jan 02, 2013 10:07 am

Step 28 of the assembly instructions calls for plugging in the board and measuring the voltage output at the end of a diode. When I do this I'm seeing not 60 VDC, but closer to .6 VDC (I've checked the scale of my mulimeter several times). Up to this point everything has seemed to work correctly. Any help would be greatly appreciated!
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am

Re: Ice Tube Clock

by adafruit_support_bill on Wed Jan 02, 2013 10:14 am

Did all the previous voltage tests & the beep test pass? If you post photos of the front & back of the board we will check your assembly so far.
User avatar
adafruit_support_bill
 
Posts: 27972
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock

by Livids on Wed Jan 02, 2013 11:11 am

yes- all previous tests passed. Though step 11 (voltage regulator) now does not pass - (a clue??)

trying to post photos...
DSC_4974.jpg
DSC_4974.jpg (155.38 KiB) Viewed 2035 times

DSC_4975.jpg
DSC_4975.jpg (73.91 KiB) Viewed 2035 times

DSC_4976.jpg
DSC_4976.jpg (73.92 KiB) Viewed 2035 times
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am

Re: Ice Tube Clock

by Livids on Wed Jan 02, 2013 11:14 am

more photos
DSC_4977.jpg
DSC_4977.jpg (83.14 KiB) Viewed 2033 times

DSC_4978.jpg
DSC_4978.jpg (111.07 KiB) Viewed 2033 times

DSC_4979.jpg
DSC_4979.jpg (120.37 KiB) Viewed 2033 times
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am

Re: Ice Tube Clock

by adafruit_support_bill on Wed Jan 02, 2013 11:19 am

Though step 11 (voltage regulator) now does not pass - (a clue??)

What voltages are you seeing on the output of the voltage regulator?
Do you still get the beep on power-up?
User avatar
adafruit_support_bill
 
Posts: 27972
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock

by Livids on Wed Jan 02, 2013 11:26 am

I'm no longer getting a beep on power up
The voltage on the bottom most (if the plug is on the top of the board) pin is .91 v
middle and top pin are essentially zero
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am

Re: Ice Tube Clock

by adafruit_support_bill on Wed Jan 02, 2013 12:22 pm

That means you probably have a short circuit somewhere. It looks like Q2 might be installed backwards. The two pins that are bridged together should be on the side closest to the diode:

Image
User avatar
adafruit_support_bill
 
Posts: 27972
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock

by Livids on Wed Jan 02, 2013 12:38 pm

You are good! I think that you are right - I completely misread the step 23 instructions (I won't elaborate on how I interpreted them - it seems pretty ridiculous in retrospect). I'll be unsoldering and resoldering later today - I'll let you know how things work out. Thanks!!
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am

Re: Ice Tube Clock

by Livids on Wed Jan 02, 2013 9:57 pm

The high voltage transistor did not survive (at least it's not looking good) the surgery. Is it possible to order a new one? Is it a fairly standard part (available at the local radio shack), or would I be best off purchasing directly from adafruit (or, third option, specialty electronics supply house in/around SF, CA??)
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am

Re: Ice Tube Clock

by adafruit_support_bill on Thu Jan 03, 2013 6:12 am

We don't have them for individual sale, but we have a couple of sources listed in the parts finder : http://www.ladyada.net/wiki/partselector/transistors?s[]=irfd110#mosfet

I'm sure that there are some local sources in the SF area too.
User avatar
adafruit_support_bill
 
Posts: 27972
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock

by ericyeh on Sat Jan 05, 2013 2:28 pm

ericyeh
 
Posts: 5
Joined: Wed Dec 26, 2012 1:28 am

Re: Ice Tube Clock

by adafruit_support_bill on Sat Jan 05, 2013 3:17 pm

@ericyeh - We need to see more detail on the soldering. Some close-ups of the boards like the ones Livids posted earlier in this thread would be ideal.
User avatar
adafruit_support_bill
 
Posts: 27972
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock

by Livids on Sat Jan 12, 2013 7:58 pm

going back a few posts - I purchased a new high voltage transistor from mouser, and all looks good so far!! Thanks so much for your help!! (it beeps when plugged in, and we are seeing the described voltage behavior in step 28.
Livids
 
Posts: 8
Joined: Wed Jan 02, 2013 10:00 am