Standard LCD 16x2 + extras (Not Working)
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Standard LCD 16x2 + extras (Not Working)

by Interstate90 on Tue Jan 15, 2013 12:59 am

Hello,

I recently purchased your "Standard LCD 16x2 + extras" (http://www.adafruit.com/products/181)

I followed the tutorial described in http://learn.adafruit.com/drive-a-16x2-lcd-directly-with-a-raspberry-pi

I have wired everything up correctly using a half sized breadboard. (per this step: http://learn.adafruit.com/assets/1751)
However, I do not see any white boxes of any kind. I have tested the 10k Pot with a multimeter and it works correctly.
I have checked, double checked and triple checked my wiring. Visually and with a multimeter (its only a few connections).
I searched the forums and could not find a solution. (closest thing I could find was http://forums.adafruit.com/viewtopic.php?f=50&t=35404&hilit=16x2 -- In which the user had to replace the LCD.

What exactly should I do now? Is there something else I can try?

Thanks
Interstate90
 
Posts: 3
Joined: Tue Jan 15, 2013 12:24 am

Re: Standard LCD 16x2 + extras (Not Working)

by adafruit_support_bill on Tue Jan 15, 2013 6:11 am

Post a photo of the wiring you have so far.
Also, check your breadboard power rails. On some breadboards, the rails are split in the middle and there is no continuity from one end of the breadboard to the other. If wired as in the tutorial on a split-rail breadboard, the contrast circuit display would not be getting power.
User avatar
adafruit_support_bill
 
Posts: 29765
Joined: Sat Feb 07, 2009 9:11 am

Re: Standard LCD 16x2 + extras (Not Working)

by Interstate90 on Sat Jan 26, 2013 6:21 pm

I wanted to let you know that I tracked down this problem to the half size breadboard I got from R-Shack. I ordered a full-size breadboard from your site and everything is working exactly as it should. Thanks!!

However, now I am running into a different problem with the python script.

I have a rev 2 board, so I followed the steps to change line #57 of "Adafruit_CharLCD.py" from pin 21 to pin 27. After running the script, I get the following error:
Code: Select all | TOGGLE FULL SIZE
/home/pi/Adafruit-Raspberry-Pi-Python-Code/Adafruit_CharLCD/Adafruit_CharLCD.py:
68: RuntimeWarning: This channel is already in use, continuing anyway.  Use GPIO
.setwarnings(False) to disable warnings.
  self.GPIO.setup(self.pin_e, GPIO.OUT)
/home/pi/Adafruit-Raspberry-Pi-Python-Code/Adafruit_CharLCD/Adafruit_CharLCD.py:
69: RuntimeWarning: This channel is already in use, continuing anyway.  Use GPIO
.setwarnings(False) to disable warnings.
  self.GPIO.setup(self.pin_rs, GPIO.OUT)
/home/pi/Adafruit-Raspberry-Pi-Python-Code/Adafruit_CharLCD/Adafruit_CharLCD.py:
72: RuntimeWarning: This channel is already in use, continuing anyway.  Use GPIO
.setwarnings(False) to disable warnings.
  self.GPIO.setup(pin, GPIO.OUT)


Any advice on what to do?
Interstate90
 
Posts: 3
Joined: Tue Jan 15, 2013 12:24 am

Re: Standard LCD 16x2 + extras (Not Working)

by tldr on Sat Jan 26, 2013 9:56 pm

the last time you ran your code you did not clean up after yourself.

according to this the following will take care of necessary housekeeping.

Code: Select all | TOGGLE FULL SIZE
GPIO.cleanup()


never hurts to search the web for an error message.
"If I had known it was harmless, I would have killed it myself." - Phillip K. Dick, A Scanner Darkly
User avatar
tldr
 
Posts: 466
Joined: Thu Aug 30, 2012 12:34 am

Re: Standard LCD 16x2 + extras (Not Working)

by Interstate90 on Sat Jan 26, 2013 11:46 pm

Thanks.

This doesn't seem to do the trick. I have only followed the tutorials on Adafruit.

Adding
Code: Select all | TOGGLE FULL SIZE
try:
      main
except: KeyboardInterrupt:
      GPIO.cleanup()


produces the error:
Code: Select all | TOGGLE FULL SIZE
./Adafruit_CharLCD.py:68: RuntimeWarning: This channel is already in use, contin
uing anyway.  Use GPIO.setwarnings(False) to disable warnings.
  self.GPIO.setup(self.pin_e, GPIO.OUT)
./Adafruit_CharLCD.py:69: RuntimeWarning: This channel is already in use, contin
uing anyway.  Use GPIO.setwarnings(False) to disable warnings.
  self.GPIO.setup(self.pin_rs, GPIO.OUT)
./Adafruit_CharLCD.py:72: RuntimeWarning: This channel is already in use, contin
uing anyway.  Use GPIO.setwarnings(False) to disable warnings.
  self.GPIO.setup(pin, GPIO.OUT)
Traceback (most recent call last):
  File "./Adafruit_CharLCD.py", line 263, in <module>
    main
NameError: name 'main' is not defined


typing
Code: Select all | TOGGLE FULL SIZE
KeyboardInterrupt:
      GPIO.cleanup()

does not do the trick

Any other suggestions? I am not sure what to do now.
Interstate90
 
Posts: 3
Joined: Tue Jan 15, 2013 12:24 am

Re: Standard LCD 16x2 + extras (Not Working)

by tldr on Sun Jan 27, 2013 1:38 am

i would try just dropping the GPIO.cleanup () call into your code just before the end. presumably you will get the warnings the first time you run the code since the i/o will already be allocated, but i think subsequent runs should be ok. the important thing is to release the resources before your program exits.
"If I had known it was harmless, I would have killed it myself." - Phillip K. Dick, A Scanner Darkly
User avatar
tldr
 
Posts: 466
Joined: Thu Aug 30, 2012 12:34 am