Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

ds1307 and RPi: Not setting correct time on boot

by katesfb on Mon Jan 28, 2013 10:28 pm

Hi,
I have a rasp pi running a DS1307 breakout board as the RTC and followed the instructions in the "adding a real time clock to raspberry pi" tutorial. Every thing works fine except that the correct time is not being set on reboot. I have to use "sudo hwclock -s" to set the correct time from that stored in teh DS1307 and this works fine.

I have added the correct entries to /etc/modules and etc/rc.local as indicated in the tutorial (rtc-1307 added to the end of /etc/modules and echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-0/new_device added before exit in rc.local) but should hwclock -s be there as well to actually set the time?

Any help is much appreciated.

Cheers.
katesfb
 
Posts: 12
Joined: Mon May 07, 2012 5:37 pm

Re: ds1307 and RPi: Not setting correct time on boot

by adafruit on Tue Jan 29, 2013 11:30 am

yes it should, please try that, does it work? :)
User avatar
adafruit
 
Posts: 11509
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

Re: ds1307 and RPi: Not setting correct time on boot

by katesfb on Fri Feb 01, 2013 6:08 am

Hi,
And thanks for the reply. I added the line "hwclock -s" to /etc/rc.local after "echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-0/new_device" but this had no effect on reboot - still had to use hwclock -s manually to set the correct time.

Any ideas?

Any help is much appreciated.

Cheers.
katesfb
 
Posts: 12
Joined: Mon May 07, 2012 5:37 pm

Re: ds1307 and RPi: Not setting correct time on boot

by adafruit on Wed Feb 06, 2013 11:29 pm

No idea :/ we'll try to check this out next time we look at the tutorial.
User avatar
adafruit
 
Posts: 11509
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc