Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

16-Channel 12-bit PWM/Servo Driver not detected

by DaWooShit on Sun Apr 14, 2013 8:25 am

So I recieved my Servo driver from adafruit about one week ago and I have been trying to get it to work (using this tutorial: http://learn.adafruit.com/adafruit-16-c ... i/overview).
But everytime I do "sudo i2cdetect -y 1" it wont show up...

So I tryed:
- "sudo i2cdetect -y 0"
- Checking for cold solder joints
- Powering the board with 2 AA batteries insted of the 3.3volt rail on the raspberry itself
- Checking the setup, over and over again

I have checked:
http://learn.adafruit.com/assets/3059
to make sure I hooked it up correctly. But I was still unable to get it to work.

Am I just underpowering the board? (The green light is lit) or whats the problem?
DaWooShit
 
Posts: 2
Joined: Wed Mar 27, 2013 4:36 pm

Re: 16-Channel 12-bit PWM/Servo Driver not detected

by adafruit_support_bill on Sun Apr 14, 2013 9:10 am

Which Pi do you have, the 256MB or 512MB model?
If you post a photo showing your soldering and one showing your connections we'll check it over.
User avatar
adafruit_support_bill
 
Posts: 28214
Joined: Sat Feb 07, 2009 9:11 am

Re: 16-Channel 12-bit PWM/Servo Driver not detected

by DaWooShit on Sun Apr 14, 2013 11:57 am

Turns out it was an unstable powersupply... Im soo sorry to have bothered you guys.
The board works like a charm, no more problems here.

PS: thanks for providing cheap (by danish standarts) hobby electronics with easy to read tutorials.
DaWooShit
 
Posts: 2
Joined: Wed Mar 27, 2013 4:36 pm