Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Tue May 21, 2013 5:56 pm

Thanks. I still think this is a Q3 issue. Not sure why the replacement didn't work. I'm checking with some of the other engineers to see if we can get to the bottom of this.
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Wed May 22, 2013 3:51 pm

OK. A couple more of these have turned up with the same symptoms. We'd like to get our hands on one to see if we can figure out what is going on. Would you be willing to send yours in for analysis?
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by sensae on Wed May 22, 2013 4:32 pm

Sure, I don't mind. Just let me know what you need me to do.
sensae
 
Posts: 10
Joined: Sun Apr 14, 2013 8:02 pm

Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Wed May 22, 2013 5:09 pm

Contact support@adafruit.com with a link to this thread and they will give you details on how and where to send your clock.
Thanks for helping out!
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by valu8er on Wed Jun 05, 2013 3:50 am

I am interested to know if there has there been any further progress toward a solution on this issue?
valu8er
 
Posts: 8
Joined: Wed Mar 27, 2013 6:35 am

Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Wed Jun 05, 2013 6:03 am

We are still waiting for the clock. Does anyone else have one they are willing to send in?
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by valu8er on Wed Jun 05, 2013 7:57 am

I am very happy to send mine in. I am located in Australia.
valu8er
 
Posts: 8
Joined: Wed Mar 27, 2013 6:35 am

Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Wed Jun 05, 2013 9:19 am

Ship-times & customs delays to/from Australia can be unpredictable. There were 4-5 other clocks with the same problem. Let's see if we can get any local volunteers first.
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by atanas on Sun Jun 09, 2013 12:39 am

I seem to be having a problem that was traced back to this one. A more detailed description is on this thread:
http://forums.adafruit.com/viewtopic.php?f=41&t=39995&p=201740#p201740

I see there has been no activity on this thread for a few months. I would be willing to send my clock in if this is going to help speed up the process. I am located in the US.
atanas
 
Posts: 4
Joined: Sun Jun 09, 2013 12:09 am

Re: Ice Tube Clock - No Beep

by atanas on Sun Jun 09, 2013 1:48 am

Oops, looks like I was looking at the wrong date when I posted my previous message. Anyway, my offer to send the clock still stands.
atanas
 
Posts: 4
Joined: Sun Jun 09, 2013 12:09 am

Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Sun Jun 09, 2013 5:24 am

@atanas - Thanks for the clock offer. We do want to get to the bottom of this. Please contact support@adafruit.com with a link to this thread for instructions on shipping your clock.
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by sensae on Tue Jun 18, 2013 8:40 pm

Has my ice clock not been received yet by Adafruit? It took a little while for the box to get to me, but I dropped it in the post about 10 days ago.
sensae
 
Posts: 10
Joined: Sun Apr 14, 2013 8:02 pm

Re: Ice Tube Clock - No Beep

by adafruit_support_bill on Wed Jun 19, 2013 8:03 am

Yes, we have received the clock.
Thank you for working with us on this. :D
User avatar
adafruit_support_bill
 
Posts: 28125
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube Clock - No Beep

by adafruit on Wed Jun 19, 2013 1:31 pm

The MOSFET ZVP3306 is now in a 'backwards' looking package with the text on the curved side instead of the flat side. the FET must be turned around and solder the other way. If you shipped your kit to adafruit this was repaired and you can email support@adafruit to get it back.

instructions will be updated shortly, thanks!
User avatar
adafruit
 
Posts: 11643
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

Re: Ice Tube Clock - No Beep

by HolstCentre on Thu Jun 20, 2013 8:48 am

I did also have problems with non working display segments of the Ice Tube.

It seems to be that there are some spikes coming from the microprocessor, corrupting the timing sequence of the display driver chip.
This problem is simlpy solved by placing some 1000 pF capacitors from the clock and data driver lines to earth. See the picture.
P6200006 (1024x768).jpg
just add these caps to this place
P6200006 (1024x768).jpg (439.3 KiB) Viewed 860 times

Adding these capacitors in this way solved the problem completedly.
Also the most right digit of the display was less bright than the others. This can be solved by adding another 22 Ohm resistor parrallel to the other (see picture).
P6200002 (1024x768).jpg
adding another 22 Ohm resistor
P6200002 (1024x768).jpg (448.33 KiB) Viewed 860 times

Also the zvp3306 should be replaced by another FET a ZVP2110.
P6200008 (768x1024).jpg
change to ZVP2110
P6200008 (768x1024).jpg (351.34 KiB) Viewed 860 times
The characteristics of this FET suits better the voltages of the circuit.
After all these modifications my Ice Tube is working fine now for some weeks without any problem. :D

I hope anyone else can make use of these suggestions.
HolstCentre
 
Posts: 1
Joined: Thu Jun 13, 2013 5:47 am
Location: eindhoven , netherlands